Bug 174563 - anaconda crashes initializing the passwd file with /usr/sbin/usermod error
anaconda crashes initializing the passwd file with /usr/sbin/usermod error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 00:25 EST by G.Wolfe Woodbury
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 22:52:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump of exception - date of rawhide 2005-11-29 (822.08 KB, text/plain)
2005-11-30 00:28 EST, G.Wolfe Woodbury
no flags Details

  None (edit)
Description G.Wolfe Woodbury 2005-11-30 00:25:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
rawhide of 2005-11-29, install proceeds normally until anaconda goes to write the passwd file with the root passwd.  It produces a traceback with the ultimate error of "/usr/sbin/usermod can not be run"

Anaconda dump attached below.

Version-Release number of selected component (if applicable):
anaconda-10.90.8-1

How reproducible:
Always

Steps to Reproduce:
1.install rawhide mirrored to 2005-11-29
2.
3.
  

Actual Results:  traceback

Expected Results:  write the passwd file and proceed to install grub, etc...

Additional info:

work1: Celeron (Coppermine) @ 500MHz on MSI motherboard
       256 MB RAM       VIA chipset
Comment 1 G.Wolfe Woodbury 2005-11-30 00:28:39 EST
Created attachment 121623 [details]
anaconda dump of exception - date of rawhide 2005-11-29

also at http://wolves.homeip.net/~ggw/texts/anacdump.txt.20051130
Comment 2 Jeremy Katz 2005-11-30 22:52:40 EST
This is being caused by the selinux policy changes requiring some changes to how
anaconda uses policy -- hopefully fixed for tomorrow's rawhide

Note You need to log in before you can comment on or make changes to this bug.