Bug 174567 - Eclipse doesn't synchronize a project with CVS
Eclipse doesn't synchronize a project with CVS
Status: CLOSED DUPLICATE of bug 163079
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 04:02 EST by Eduardo Yáñez Parareda
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 09:34:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Yáñez Parareda 2005-11-30 04:02:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Eclipse shows me an error when I try to synchronize some project with CVS:

'An Internal error ocurred during: "Synchronizing CVS (/custoval)".

Eclipse throws an ArrayIndexOutOfBoundsException when synchronizing a project with CVS. That's the stacktrace:

!SESSION 2005-11-30 09:33:10.796 -----------------------------------------------
eclipse.buildId=M20050929-0840
java.fullversion=GNU libgcj 4.0.1 20050727 (Red Hat 4.0.1-5)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86 -data /home/eyp/workspace

!ENTRY org.eclipse.core.resources 2 10035 2005-11-30 09:33:17.46
!MESSAGE A workspace crash was detected. The previous session did not exit normally.

!ENTRY org.eclipse.core.runtime 4 2 2005-11-30 09:41:36.360
!MESSAGE An internal error occurred during: "Synchronizing CVS (/custoval)".
!STACK 0
java.lang.ArrayIndexOutOfBoundsException: 0
   at org.eclipse.team.internal.ccvs.core.syncinfo.CVSResourceVariantTree.fetchMembers(org.eclipse.team.core.variants.IResourceVariant, org.eclipse.team.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.cvs.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.AbstractResourceVariantTree.mergedMembers(org.eclipse.core.resources.IResource, org.eclipse.team.core.variants.IResourceVariant, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.AbstractResourceVariantTree.collectChanges(org.eclipse.core.resources.IResource, org.eclipse.team.core.variants.IResourceVariant, java.util.Collection, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.AbstractResourceVariantTree.collectChanges(org.eclipse.core.resources.IResource, org.eclipse.team.core.variants.IResourceVariant, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.ResourceVariantTree.access$0(org.eclipse.team.core.variants.ResourceVariantTree, org.eclipse.core.resources.IResource, org.eclipse.team.core.variants.IResourceVariant, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.ResourceVariantTree$1.run(org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.core.internal.resources.Workspace.run(org.eclipse.core.resources.IWorkspaceRunnable, org.eclipse.core.runtime.jobs.ISchedulingRule, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.core.resources_3.1.0.jar.so)
   at org.eclipse.team.core.variants.PersistantResourceVariantByteStore.run(org.eclipse.core.resources.IResource, org.eclipse.core.resources.IWorkspaceRunnable, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.internal.core.subscribers.DescendantResourceVariantByteStore.run(org.eclipse.core.resources.IResource, org.eclipse.core.resources.IWorkspaceRunnable, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.ResourceVariantTree.collectChanges(org.eclipse.core.resources.IResource, org.eclipse.team.core.variants.IResourceVariant, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.internal.ccvs.core.syncinfo.CVSResourceVariantTree.collectChanges(org.eclipse.core.resources.IResource, org.eclipse.core.variants.IResourceVariant, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.cvs.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.AbstractResourceVariantTree.refresh(org.eclipse.core.resources.IResource, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.internal.ccvs.core.syncinfo.CVSResourceVariantTree.refresh(org.eclipse.core.resources.IResource, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.cvs.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.AbstractResourceVariantTree.refresh(org.eclipse.core.resources.IResource[], int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.ResourceVariantTreeSubscriber.refresh(org.eclipse.core.resources.IResource, int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.core.variants.ResourceVariantTreeSubscriber.refresh(org.eclipse.core.resources.IResource[], int, org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.core_3.1.1.jar.so)
   at org.eclipse.team.internal.ui.synchronize.RefreshSubscriberJob.run(org.eclipse.core.runtime.IProgressMonitor) (/usr/lib/gcj/eclipse/org.eclipse.team.ui_3.1.1.jar.so)
   at org.eclipse.core.internal.jobs.Worker.run() (/usr/lib/gcj/eclipse/org.eclipse.core.runtime_3.1.1.jar.so)
   at .GC_start_routine (/usr/lib/libgcj.so.6.0.0)
   at .__clone (/lib/libc-2.3.5.so)


Version-Release number of selected component (if applicable):
eclipse-platform-3.1.1-1jpp_1fc.FC4.4

How reproducible:
Always

Steps to Reproduce:
1. Open Eclipse
2. Java perspective, right button on a project.
3. Select Team->Synchronize with Repository
  


Actual Results:  Eclipse shows me an error when I try to synchronize some project with CVS:

'An Internal error ocurred during: "Synchronizing CVS (/custoval)".



Expected Results:  I want my project synchronized with CVS.

Additional info:

I can't work with the native version of Eclipse because of this bug.
Comment 1 Andrew Overholt 2005-11-30 09:34:10 EST
You are in luck!  gcc 4.0.2 was just released as an FC4 update and I am
rebuilding eclipse with it as we speak.  When that finishes, I will put it in
updates-testing and you can verify that the bug is fixed :)

*** This bug has been marked as a duplicate of 163079 ***

Note You need to log in before you can comment on or make changes to this bug.