Bug 174584 - Abiword depends on libgnomedb but doesn't seem to use it
Abiword depends on libgnomedb but doesn't seem to use it
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 09:21 EST by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 03:38:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2005-11-30 09:21:39 EST
Hi,

Because I'm going to update libgnomedb in devel soon, I have taken a look at
programs requiring it.

abiword's specfile contains:
Requires: libgnomedb >= 1.0.4

However abiword does not seem to use it I did the following to see if it used
any libs or other files installed by libgnomedb:
[hans@guest-dhcp-133 plugins]$ rpm -ql abiword|xargs grep gnomedb
[hans@guest-dhcp-133 plugins]$ rpm -ql abiword|xargs grep gnome-db
[hans@guest-dhcp-133 plugins]$ rpm -ql abiword|xargs grep gnome-database

This should catch usage of any libgnomedb installed file/executable and/or library.

The Requires isn't really a problem for my upgrade since abiword's dependecies
will still be matched by the upgraded version, but the Requires seems unnescesarry.
Comment 1 Marc Maurer 2005-12-02 06:47:24 EST
The GDA plugin uses it afaik. Will double check soonish.
Comment 2 Hans de Goede 2005-12-02 09:38:04 EST
That plugin doesn't seem to be included in the package:
[hans@shalem ~]$ ls /usr/lib64/AbiWord-2.4/plugins/libAbi*
/usr/lib64/AbiWord-2.4/plugins/libAbiAikSaurus.so
/usr/lib64/AbiWord-2.4/plugins/libAbiApplix.so
/usr/lib64/AbiWord-2.4/plugins/libAbiBMP.so
/usr/lib64/AbiWord-2.4/plugins/libAbiBabelfish.so
/usr/lib64/AbiWord-2.4/plugins/libAbiCAPI.so
/usr/lib64/AbiWord-2.4/plugins/libAbiClarisWorks.so
/usr/lib64/AbiWord-2.4/plugins/libAbiCollab.so
/usr/lib64/AbiWord-2.4/plugins/libAbiDash.so
/usr/lib64/AbiWord-2.4/plugins/libAbiDocBook.so
/usr/lib64/AbiWord-2.4/plugins/libAbiEML.so
/usr/lib64/AbiWord-2.4/plugins/libAbiFreeTranslation.so
/usr/lib64/AbiWord-2.4/plugins/libAbiGdict.so
/usr/lib64/AbiWord-2.4/plugins/libAbiGimp.so
/usr/lib64/AbiWord-2.4/plugins/libAbiGoogle.so
/usr/lib64/AbiWord-2.4/plugins/libAbiGrammar.so
/usr/lib64/AbiWord-2.4/plugins/libAbiHRText.so
/usr/lib64/AbiWord-2.4/plugins/libAbiHancom.so
/usr/lib64/AbiWord-2.4/plugins/libAbiISCII.so
/usr/lib64/AbiWord-2.4/plugins/libAbiJPEG.so
/usr/lib64/AbiWord-2.4/plugins/libAbiKWord.so
/usr/lib64/AbiWord-2.4/plugins/libAbiLaTeX.so
/usr/lib64/AbiWord-2.4/plugins/libAbiMIF.so
/usr/lib64/AbiWord-2.4/plugins/libAbiMSWrite.so
/usr/lib64/AbiWord-2.4/plugins/libAbiMathView.so
/usr/lib64/AbiWord-2.4/plugins/libAbiNroff.so
/usr/lib64/AbiWord-2.4/plugins/libAbiOTS.so
/usr/lib64/AbiWord-2.4/plugins/libAbiOpenDocument.so
/usr/lib64/AbiWord-2.4/plugins/libAbiOpenWriter.so
/usr/lib64/AbiWord-2.4/plugins/libAbiPalmDoc.so
/usr/lib64/AbiWord-2.4/plugins/libAbiPassepartout.so
/usr/lib64/AbiWord-2.4/plugins/libAbiRSVG.so
/usr/lib64/AbiWord-2.4/plugins/libAbiSDW.so
/usr/lib64/AbiWord-2.4/plugins/libAbiScriptHappy.so
/usr/lib64/AbiWord-2.4/plugins/libAbiT602.so
/usr/lib64/AbiWord-2.4/plugins/libAbiURLDict.so
/usr/lib64/AbiWord-2.4/plugins/libAbiWMF.so
/usr/lib64/AbiWord-2.4/plugins/libAbiWML.so
/usr/lib64/AbiWord-2.4/plugins/libAbiWikipedia.so
/usr/lib64/AbiWord-2.4/plugins/libAbiWordPerfect.so
/usr/lib64/AbiWord-2.4/plugins/libAbiXHTML.so
/usr/lib64/AbiWord-2.4/plugins/libAbiXSLFO.so
Comment 3 Marc Maurer 2005-12-05 07:23:25 EST
Erm, duh :-P I disabled the GDA plugin and didn't remove depends. I'll fix this
issue soonish, feel free to continu with your update of gda/gnomedb.
Comment 4 Hans de Goede 2006-01-17 03:38:44 EST
I saw that you've fixed this in CVS, closing.

Note You need to log in before you can comment on or make changes to this bug.