Bug 174604 - Galeon gives and error saying problem with gconf schema
Galeon gives and error saying problem with gconf schema
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 12:26 EST by Nathan G. Grennan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 00:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2005-11-30 12:26:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050923 Galeon/2.0.0

Description of problem:
I have FC5 Test 1 installed and it is updated to the latest rawhide. I upgraded Galeon from 1.3.21 to 2.0.0. After doing so, on startup of Galeon I get an error about the gconf schema. It says you shouldn't normally see this. It also suggests a command to install the schema. I tried the command, but it didn't help.

I am running the i386 Galeon on a x86_64 computer. I do this for plugins. The FC4 version of Galeon 2.0.0-1 works on another x86_64 computer running FC4. The FC4 version also works on my FC5 x86_64 computer. So it seems to be something isolated to the FC5 version of the package.

Version-Release number of selected component (if applicable):
2.0.0-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to galeon-2.0.0-1.fc5
2. Start galeon

  

Actual Results:  Problem with gconf schema error message

Expected Results:  Problem starts with no errors

Additional info:
Comment 1 Yanko Kaneti 2005-11-30 17:03:50 EST
I'd say the gconf dealing part of the spec should be changed according to
http://www.fedoraproject.org/wiki/ScriptletSnippets#head-ff64cd482595764f672082d5a3b83e1fc22962e8
which admittedly looks ugly but I guess works

more discussion on the kill issue happened here
https://www.redhat.com/archives/fedora-extras-list/2005-October/msg00235.html

This also means ditching galeon-config-tool, which can only be considered a good
thing. 
Comment 2 Denis Leroy 2005-12-05 00:19:59 EST
Ok, i fixed this. The schemas uninstall in the %preun script was not protected
correctly, causing the schemas to be removed at the end of the update process. I
took the opportunity to get rid of galeon-config-tool and use more standard
Fedora gconf scriplets.

Unfortunately, because the %preun and %postun scripts of the old package are ran
last, updating to galeon-2.0.0-2 with rpm -U will not fix the problem. You
*need* to remove the existing version first, then install the new version.
Updates will work fine with future versions. Fortunately, this bug is only
present in rawhide, so upgrading from the FC4 version will work.

Note You need to log in before you can comment on or make changes to this bug.