Bug 174626 - 1920x1200 laptop screen only runs at 1600x1200 even though config shows right values
1920x1200 laptop screen only runs at 1600x1200 even though config shows right...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 177581 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 15:32 EST by Rodd Clarkson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 17:40:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5715 None None None Never

  None (edit)
Description Rodd Clarkson 2005-11-30 15:32:37 EST
Description of problem:

I have a laptop (Dell Inspiron 9300) with a 1920x1200 resolution screen.

When I configure Xorg, the screen resolution is listed, and the config file sets
up with resolutions appropriate to the monitor.  (See xorg.conf file below).

However, when I run gnome, it only displays at 1600x1200 and Settings >
Preferences > Screen Resolution doesn't have options for anything larger than
1600x1200.

I looked in my gconf settings and it shows Screen Resolution as 1920x1200 (from
before the move to modular xorg) but it won't display at this resolution.

The option presented in the screen resolution preferences dialog are:

1600x1200
1400x1050
1280x960
1280x1024
1024x768
800x600
640x480

My /etc/X11/xorg.conf file looks like this:

--------------------------------------------------------------------

# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Synaptics" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules"
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "synaptics"
	Load  "glx"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons" "yes"
	Option	    "LeftEdge" "120"
	Option	    "RightEdge" "830"
	Option	    "TopEdge" "120"
	Option	    "BottomEdge" "650"
	Option	    "FingerLow" "14"
	Option	    "FingerHigh" "15"
	Option	    "MaxTapMove" "110"
	Option	    "VertScrollDelta" "20"
	Option	    "HorizScrollDelta" "20"
	Option	    "MinSpeed" "0.3"
	Option	    "MaxSpeed" "0.75"
	Option	    "AccelFactor" "0.0300"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "LCD Panel 1920x1200"
	HorizSync    31.5 - 90.0
	VertRefresh  60.0 - 60.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA Unknown (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1920x1200" "1920x1440" "1680x1050" "1600x1200" "1400x1050"
"1280x960" "1280x800" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
--------------------------------------------------------------------


Version-Release number of selected component (if applicable):

[rodd@localhost ~]$ rpm -qa xorg\*
xorg-x11-drv-mouse-1.0.1-2
xorg-x11-drv-neomagic-1.0.0.2-1
xorg-x11-drv-fpit-1.0.0.2-1
xorg-x11-drv-trident-1.0.0.2-1
xorg-x11-drv-calcomp-1.0.0.2-1
xorg-x11-drv-jamstudio-1.0.0.2-1
xorg-x11-drv-tdfx-1.1.1-1
xorg-x11-server-Xorg-0.99.3-9
xorg-x11-fonts-misc-0.99.0-8
xorg-x11-drv-via-0.1.31.1-1
xorg-x11-xinit-0.99.3-6
xorg-x11-drv-vesa-1.0.1-1
xorg-x11-drv-i128-1.1.0.2-1
xorg-x11-drv-vmware-10.11.1-1
xorg-x11-drv-tseng-1.0.0.2-1
xorg-x11-drv-magictouch-1.0.0.2-1
xorg-x11-drv-i810-1.4.1-1
xorg-x11-drv-microtouch-1.0.0.2-1
xorg-x11-drv-ur98-1.0.0.2-1
xorg-x11-fonts-base-0.99.0-8
xorg-x11-fonts-75dpi-0.99.0-8
xorg-x11-fonts-ISO8859-1-100dpi-0.99.0-8
xorg-x11-fonts-100dpi-0.99.0-8
xorg-x11-utils-0.99.2-3
xorg-x11-twm-0.99.1-3
xorg-x11-resutils-0.99.1-3
xorg-x11-xfs-0.99.2-4
xorg-x11-drv-keyboard-1.0.1-1
xorg-x11-drv-savage-2.0.2-1
xorg-x11-drv-s3virge-1.8.6.2-1
xorg-x11-drv-s3-0.3.5.2-1
xorg-x11-drv-dmc-1.0.0.2-1
xorg-x11-drv-siliconmotion-1.3.1.2-1
xorg-x11-drv-voodoo-1.0.0.2-1
xorg-x11-drv-cirrus-1.0.0.2-1
xorg-x11-drv-void-1.0.0.2-1
xorg-x11-drv-digitaledge-1.0.1-1
xorg-x11-drv-joystick-1.0.0.2-1
xorg-x11-drv-apm-1.0.1.2-1
xorg-x11-drv-penmount-1.0.0.2-1
xorg-x11-drv-magellan-1.0.0.2-1
xorg-x11-drivers-0.99.2-4
xorg-x11-drv-nv-1.0.1.2-1
xorg-x11-font-utils-0.99.1-1
xorg-x11-filesystem-0.99.2-3
xorg-x11-fonts-ISO8859-1-75dpi-0.99.0-8
xorg-x11-xfwp-0.99.1-3
xorg-x11-apps-0.99.2-4
xorg-x11-drv-i740-1.0.0.2-1
xorg-x11-drv-sis-0.8.1-1
xorg-x11-drv-citron-2.1.1.2-1
xorg-x11-drv-chips-1.0.1-1
xorg-x11-drv-sisusb-0.7.1-1
xorg-x11-drv-fbdev-0.1.0.2-1
xorg-x11-drv-spaceorb-1.0.0.2-1
xorg-x11-drv-acecad-1.0.0.2-1
xorg-x11-drv-ati-6.5.7-1
xorg-x11-drv-mga-1.2.1-1
xorg-x11-drv-cyrix-1.0.0.2-1
xorg-x11-drv-mutouch-1.0.0.2-1
xorg-x11-drv-hyperpen-1.0.0.2-1
xorg-x11-xkb-utils-0.99.1-2
xorg-x11-xauth-0.99.2-1
xorg-x11-proto-devel-0.99.2-3
xorg-x11-drv-elo2300-1.0.0.2-1
xorg-x11-drv-summa-1.0.0.2-1
xorg-x11-drv-elographics-1.0.0.2-1
xorg-x11-drv-ark-0.5.0.2-1
xorg-x11-drv-evdev-1.0.0.2-1
xorg-x11-drv-aiptek-1.0.0.2-1
xorg-x11-server-utils-0.99.2-6
xorg-x11-fonts-Type1-0.99.0-8
xorg-x11-xkbdata-0.99.1-2
xorg-x11-xsm-0.99.2-4
xorg-x11-xdm-0.99.3-6
xorg-x11-drv-vga-4.0.0.2-1
xorg-x11-drv-nsc-2.7.6.2-1
xorg-x11-drv-dynapro-1.0.0.2-1
xorg-x11-drv-dummy-0.1.0.2-1
xorg-x11-drv-rendition-4.0.1-1
xorg-x11-drv-palmax-1.0.0.2-1
xorg-x11-drv-glint-1.0.1-1
[rodd@localhost ~]$
Comment 1 Mike A. Harris 2005-11-30 20:18:55 EST
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "CANTFIX" (unsupported).
Comment 2 Rodd Clarkson 2005-12-14 06:57:03 EST
Okay, let's reopen this as I'm seeing it on the stock nv driver on a stock
install of FC5t1.

Here's my xorg.conf file:

-----------------------------------------------------------
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Synaptics" "CorePointer"
	InputDevice    "Mouse0" "AlwaysCore"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "synaptics"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons" "yes"
	Option	    "LeftEdge" "120"
	Option	    "RightEdge" "830"
	Option	    "TopEdge" "120"
	Option	    "BottomEdge" "650"
	Option	    "FingerLow" "14"
	Option	    "FingerHigh" "15"
	Option	    "MaxTapMove" "110"
	Option	    "VertScrollDelta" "20"
	Option	    "HorizScrollDelta" "20"
	Option	    "MinSpeed" "0.3"
	Option	    "MaxSpeed" "0.75"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "LCD Panel 1920x1200"
	HorizSync    31.5 - 90.0
	VertRefresh  60.0 - 60.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nv"
	VendorName  "Videocard vendor"
	BoardName   "nVidia Corporation NV41.8 [GeForce Go 6800]"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1920x1200" "1920x1440" "1680x1050" "1600x1200" "1400x1050"
"1280x960" "1280x800" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection

-----------------------------------------------------------

Here's what I've got installed:

[rodd@localhost ~]$ rpm -qa xorg\*
xorg-x11-drv-acecad-1.0.0.2-1
xorg-x11-drv-ati-6.5.7-1
xorg-x11-drv-citron-2.1.1.2-1
xorg-x11-drv-dummy-0.1.0.2-1
xorg-x11-drv-evdev-1.0.0.2-1
xorg-x11-drv-hyperpen-1.0.0.2-1
xorg-x11-drv-jamstudio-1.0.0.2-1
xorg-x11-drv-mga-1.2.1-1
xorg-x11-drv-nsc-2.7.6.2-1
xorg-x11-drv-rendition-4.0.1-1
xorg-x11-drv-siliconmotion-1.3.1.2-1
xorg-x11-drv-summa-1.0.0.2-1
xorg-x11-drv-vga-4.0.0.2-1
xorg-x11-drv-voodoo-1.0.0.2-1
xorg-x11-xauth-0.99.2-1
xorg-x11-fonts-base-0.99.0-8
xorg-x11-filesystem-0.99.2-3
xorg-x11-fonts-100dpi-0.99.0-8
xorg-x11-drv-ur98-1.0.0.2-1
xorg-x11-utils-0.99.2-3
xorg-x11-xfs-0.99.2-4
xorg-x11-drv-vesa-1.0.1-1
xorg-x11-drv-keyboard-1.0.1-1
xorg-x11-drv-aiptek-1.0.0.2-1
xorg-x11-drv-ark-0.5.0.2-1
xorg-x11-drv-calcomp-1.0.0.2-1
xorg-x11-drv-cirrus-1.0.0.2-1
xorg-x11-drv-cyrix-1.0.0.2-1
xorg-x11-drv-dmc-1.0.0.2-1
xorg-x11-drv-dynapro-1.0.0.2-1
xorg-x11-drv-elographics-1.0.0.2-1
xorg-x11-drv-fbdev-0.1.0.2-1
xorg-x11-drv-glint-1.0.1-1
xorg-x11-drv-i128-1.1.0.2-1
xorg-x11-drv-i810-1.4.1-1
xorg-x11-drv-joystick-1.0.0.2-1
xorg-x11-drv-magictouch-1.0.0.2-1
xorg-x11-drv-microtouch-1.0.0.2-1
xorg-x11-drv-neomagic-1.0.0.2-1
xorg-x11-drv-nv-1.0.1.2-1
xorg-x11-drv-penmount-1.0.0.2-1
xorg-x11-drv-s3-0.3.5.2-1
xorg-x11-drv-savage-2.0.2-1
xorg-x11-drv-sis-0.8.1-1
xorg-x11-drv-spaceorb-1.0.0.2-1
xorg-x11-drv-tdfx-1.1.1-1
xorg-x11-drv-tseng-1.0.0.2-1
xorg-x11-drv-via-0.1.31.1-1
xorg-x11-drv-void-1.0.0.2-1
xorg-x11-twm-0.99.1-3
xorg-x11-font-utils-0.99.1-1
xorg-x11-server-utils-0.99.2-6
xorg-x11-apps-0.99.2-4
xorg-x11-fonts-Type1-0.99.0-8
xorg-x11-fonts-75dpi-0.99.0-8
xorg-x11-xinit-0.99.3-6
xorg-x11-drv-mouse-1.0.1-2
xorg-x11-drivers-0.99.2-4
xorg-x11-xkb-utils-0.99.1-2
xorg-x11-xkbdata-0.99.1-2
xorg-x11-drv-apm-1.0.1.2-1
xorg-x11-drv-chips-1.0.1-1
xorg-x11-drv-digitaledge-1.0.1-1
xorg-x11-drv-elo2300-1.0.0.2-1
xorg-x11-drv-fpit-1.0.0.2-1
xorg-x11-drv-i740-1.0.0.2-1
xorg-x11-drv-magellan-1.0.0.2-1
xorg-x11-drv-mutouch-1.0.0.2-1
xorg-x11-drv-palmax-1.0.0.2-1
xorg-x11-drv-s3virge-1.8.6.2-1
xorg-x11-drv-sisusb-0.7.1-1
xorg-x11-drv-trident-1.0.0.2-1
xorg-x11-drv-vmware-10.11.1-1
xorg-x11-fonts-misc-0.99.0-8
xorg-x11-fonts-truetype-0.99.0-8
xorg-x11-server-Xorg-0.99.3-9
[rodd@localhost ~]$
Comment 3 Rodd Clarkson 2005-12-14 06:58:40 EST
It's worth noting that I'm not 'up-to-date' with devel at the moment since doing
this is a little hard with the dependency issues, but I've updated xorg\* and
I'm working through some of the other packages in small bits.
Comment 4 Rodd Clarkson 2005-12-17 17:48:25 EST
I've updated to the current rawhide release and this is still a problem.

Is there anybody listening?
Comment 5 Rodd Clarkson 2006-01-11 16:45:02 EST
I'm going to close this bug and file a new one.  It appears that the initial use
of the nvidia driver instead of nv has stopped people reading this report and
this is a regression so it needs to be addressed.
Comment 6 Mike A. Harris 2006-01-11 18:39:42 EST
(In reply to comment #5)
> I'm going to close this bug and file a new one.  It appears that the initial use
> of the nvidia driver instead of nv has stopped people reading this report and
> this is a regression so it needs to be addressed.

That is not the case.  There are hundreds of bugs in bugzilla, and each one
will get reviewed and commented on over time.  Just how long that will be
depends on various factors including how much manpower resources are available,
and what everyone's priorities are over all of the various tasks available
to work on.

Generally speaking, problems encountered while using the Nvidia proprietary
video drivers need to be reported either directly to Nvidia via their forums
as indicated above in this report, or alternatively in X.Org's bugzilla
located at http://bugs.freedesktop.org which has a component entry for the
proprietary driver, which Nvidia does review over time.  That is the official
method for reporting any problems regarding the Nvidia proprietary drivers.

If a given problem is reproduceable using the open source "nv" driver, then
the best/proper thing to do, is also to file a bug report in the X.Org
bugzilla, but file it against the "nv" driver component instead, to ensure
the right people see the problem.  There is a new maintainer for the "nv"
driver upstream, who is an Nvidia employee.

Due to the obfuscation present in the nv driver source code, and the complete
lack of public or NDA documentation, problems that occur using the open source
driver, are also generally only solveable directly by Nvidia or other people
who have deep knowledge of the inner workings of the Nvidia hardware in
question.

I've just re-reviewed this report with the updated information you've
supplied, as well as the duplicate bug report you filed (which was not
necessary, all you needed to do was to update this report to indicate
the problem still occurs with a newer version of the OS).  The problem
seems to be that the X server does not supply a built in video mode for
the resolution you would like to use.  While this is not a "bug" per se.,
it does require manual configuration of the X server as you have done in
order to get the desired video mode to work.

The best long term solution, is to file a bug report directly in X.Org
bugzilla at http://bugs.freedesktop.org against the X server, describing
the problem, and including file attachments of your X server log and
config file (please don't paste large files into the comment area of
bugzilla, it makes bugs very difficult to follow).  The summary of the
bug report should read something like:

"Enhancement request: Please add built in video mode 1920x1200 to X server"

or something of that nature.  X.Org developers will review your request,
and will probably add the mode to CVS HEAD, or alternatively reject it
with a reason.  It will probably be honoured however.

Once you have filed your enhancement request in X.org bugzilla, if you
paste the upstream bug URL here, Red Hat will track the request in X.Org
bugzilla, and once it is accepted into X.Org CVS, we will review it for
consideration in future Red Hat X.Org builds as well.

Hopefully this clarifies any confusion in this matter.
Comment 7 Mike A. Harris 2006-01-11 18:40:56 EST
*** Bug 177581 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2006-01-11 18:43:06 EST
Updating product version to "devel" to indicate feature is not present in
X11R7, which is currently present in rawhide.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream bug URL to track
upstream feature enhancement inclusion.
Comment 9 Rodd Clarkson 2006-01-11 19:39:19 EST
Mike, first of all, I didn't mean to piss you off.  I appreciate the work you do
and the time it takes.

I'm also aware of the feelings that people have toward the nvidia driver but
this is the card my laptop comes with, so it's what I'm stuck with.  Sadly, the
use of the term nvidia does turn people off and they often stop reading.

I thought I had mentioned in this bug report that it was also a problem with the
nv driver and that the problem hadn't been resolved in rawhide.  Sorry if this
wasn't clear.

Finally, and this might be something that redhat/fedora have to consider as
policy, but as a inidividual I don't have time to subscribe to every bugzilla
out there to report bugs, and I have less time to report bugs in the right place
and then everywhere else so that others can track the bug.  I really don't have
time to learn the nuances of each bugzilla and the correct protocols so as to be
take seriously.

As a result, I file bug reports in Fedora (and occassionally gnome and mozilla)
and what usually happens is that the person who's area it is files upstream if
necessary.  In this way I can belong to a few bugzilla's that make sense to me,
and they can belong to the few bugzilla's that make sense to them and everything
is a little simpler.

This saves me having to learn the correct way to handle bug reports to each
bugzilla, and also means that bug reports filed upstream are probably done in
such a way as they make sense.

I'll file the upstream report if you really want me to, but I hope you can see
the logic in what I'm saying.

I've got a work around to the problem I'm experiencing, so this isn't a really
big issue for me, but this is going to be a nightmare when people start testing
xorg in fedora and find that their wide-screen displays aren't Just Working(TM).

Again, thank you for all the great work you do toward making Fedora happen.
Comment 10 Mike A. Harris 2006-01-11 20:06:15 EST
(In reply to comment #9)

> Mike, first of all, I didn't mean to piss you off.

No problem, you haven't.  ;o)  I'm merely stating the proper path to a solution
to a problem of this nature.  To be clear, this is entirely a matter of policy
towards a solution, and is not an emotional matter.

The problem in question is an operating system independent lack of a feature
in the upstream X.Org source.  The proper place to report X.Org specific
issues that are OS independent, is in X.Org bugzilla, much like reporting
OS independent GNOME specific issues in GNOME bugzilla.

For this particular feature, eventually someone will report the issue to
X.Org and it'll probably get fixed in a future release.  If you find it
inconvenient to report directly upstream yourself, that's not a problem
really, as some other user is likely to report it to X.Org eventually
anyway, so I'm sure it will likely get fixed upstream in a future X
release.  In the mean time, this bug should stay open until someone does
report it to X.Org, and pastes the URL here for tracking.
Comment 11 Rodd Clarkson 2006-01-24 16:23:34 EST
I can't see how to set this flag, but this has been filed upstream at:

https://bugs.freedesktop.org/show_bug.cgi?id=5715
Comment 12 Mike A. Harris 2006-01-24 17:40:54 EST
Thanks for the URL, I've CC'd myself on the upstream report to track it.

Setting status to "UPSTREAM".

Note You need to log in before you can comment on or make changes to this bug.