Bug 174647 - The terminal background can not eyeable!
The terminal background can not eyeable!
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 21:11 EST by JasonY
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 14:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
It is a picture. (263.94 KB, image/png)
2005-11-30 21:11 EST, JasonY
no flags Details

  None (edit)
Description JasonY 2005-11-30 21:11:38 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Open the terminal
2.Select edit
3.Select Profiles...
4.Edit the profile
5.Into effects tab
6.Use Transparent background
7.drag item to left
  
Actual results:
If the window of behind terminal is not the desktop background,the terminal 
still eyeable the desktop background.

Expected results:
The terminal window is transparent,and the window of behind terminal is 
eyeable.

Additional info:
Comment 1 JasonY 2005-11-30 21:11:39 EST
Created attachment 121658 [details]
It is a picture.
Comment 2 Ray Strode [halfline] 2005-12-01 14:36:40 EST
Hi Jason.

Unfortunately, this is due to a limitation of X.  There is no way to get the
contents of windows that are hidden by other windows, so the transparent effect
is faked, by grabbing the picture being used for the desktop wallpaper.

There are plans to correct this limitation of X, but a lot of work still needs
to be done before fixed versions of X will be generally available.

Comment 3 JasonY 2005-12-01 20:50:35 EST
Hello,Ray
Thanks for your comment,i don't konw about limitation of X,so i submit this 
bug,sorry to have bothered you.
I used linux just a little days,so my idea looks like childish.
I want to communion with yours often.

ps: My English is poor,i hope you can understand me.

Note You need to log in before you can comment on or make changes to this bug.