Bug 17465 - Documentation inaccuracies with source install
Documentation inaccuracies with source install
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-13 04:04 EDT by Graham Leggett
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-13 04:04:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2000-09-13 04:04:33 EDT
After installing RPM from source under Solaris v2.6, the following
instructions exist to configure RPM after the "make install" step:

1. 

From INSTALL:

  You may add as many "provides: " lines as you like to /etc/rpmrc/ but
                                                                              
^^^^^^^^^^
  they can not be continued.

This is a directory, not a file. What is the file supposed to be? Neither a
file nor directory exists on my Redhat Linux system with this name. 

2.

From INSTALL:

  You should satisfy dependencies for all system libraries. For each of
  the system library directories you should run 

     echo * | find-provides.sh

No such file called find-provides.sh exists within the source archive.

3.

A file called find-provides.perl does exist - but the paths within this
file look absolutely nothing like the default install directory of RPM
(/usr/local).

4.

No further documentation seems to exist for correctly configuring RPM from
scratch. All RPM documentation seems to be for creating RPMs, not
installing RPM.
Comment 1 Jeff Johnson 2001-01-09 09:59:38 EST
1) The file is /etc/rpmrc, not to be confused with the directory /etc/rpm

2) The installed file is called find-provides, and is chosen per-platform from
autodeps/*.prov.
After install, you can find the file in (usually) /usr/lib/rpm/find-provides

3) find-provides.perl is a variant implementation, unused by rpm itself, but
used, for
example, for CPAN packages.

4) RPM is configured using macros, the complete list with descriptive text is in
(usually)
/usr/lib/rpm/macros.

Note You need to log in before you can comment on or make changes to this bug.