This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 174663 - Heavy CPU load caused by "wnck-applet"
Heavy CPU load caused by "wnck-applet"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 03:04 EST by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.14.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 10:17:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2005-12-01 03:04:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051018 Epiphany/1.8.2

Description of problem:
I frequently encounter a situation where the bottom "GNOME"
panel does not respond anymore. CPU clock and CPU load go up
to the maximum. The culprit is "wnck-applet" which keeps the
CPU essentially 100% busy like in the following snippet of
"top" output:

"2675 test 25 0 46972 10m 8480 R 96.5 2.0 0:29.22 wnck-applet"

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Login to "GNOME" session.
2. Use the system ...
  

Actual Results:  The bottom "GNOME" panel does not respond anymore. CPU clock
and CPU load go up to the maximum.

Expected Results:  The bottom "GNOME" panel should remain responsive without any
anomaly.

Additional info:

Killing "wnck-applet" does the trick. One has to
confirm reloading of the usual applets of the
bottom "GNOME" panel. Afterwards, normal operation
resumes.
Comment 1 Joachim Frieben 2005-12-01 03:05:41 EST
Version is: "gnome-panel-2.12.1-7"
Comment 2 Matthias Clasen 2006-02-16 01:06:15 EST
I have never seen this. Do you still see this issue with current rawhide ?
Comment 3 Joachim Frieben 2006-02-16 04:44:31 EST
I haven't seen it for a couple of weeks now. So, I guess, it has been
fixed in one of the "GNOME" 2.13.x snapshots.
Comment 4 Manuel Morales 2006-03-23 16:05:12 EST
I recently upgraded to FC 5 and I have also noticed this. It turns out to happen
fairly regularly when launching on program in particular (Mathematica). Let me
know if there's any info I can provide to help debug this issue.
Comment 5 Gérard Milmeister 2006-03-26 17:21:17 EST
For Mathematica, see the following:

http://forums.wolfram.com/student-support/topics/10215
Comment 6 Joachim Frieben 2006-04-03 06:12:25 EDT
Right, I can definitely confirm that the issue appears after using the
graphical frontend to "Mathematica" which is called "mathematica".
Because I usually only deal with the command line executable "math", I
hadn't observed the issue for a while and thought it was gone. However,
it is still around for the current "libwnck-2.14.0-1".
Comment 7 Ray Strode [halfline] 2006-08-04 10:17:58 EDT
I believe this got fixed in 2.14.1:

http://bugzilla.gnome.org/show_bug.cgi?id=332493

If not, feel free to reopen and we can debug the problem.

Note You need to log in before you can comment on or make changes to this bug.