Bug 174666 - old-kernels switch offers to remove running kernel
Summary: old-kernels switch offers to remove running kernel
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-01 08:57 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 14:19:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2005-12-01 08:57:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
The old-kernels switch should except the running kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Need Real Name 2006-01-10 08:27:07 UTC
This is still broken:

# uname -r ;/usr/bin/package-cleanup --oldkernels
2.6.12-1.1398_FC4smp
Setting up yum
I will remove the following 8 kernel related packages:
kernel-2.6.14-1.1644_FC4
kernel-2.6.14-1.1637_FC4
kernel-2.6.13-1.1532_FC4
kernel-2.6.13-1.1526_FC4
kernel-2.6.12-1.1456_FC4
kernel-2.6.12-1.1447_FC4
kernel-2.6.12-1.1398_FC4          <------- uh oh.
kernel-2.6.11-1.1369_FC4
Is this ok [y/N]:

Selecting "yes" seems to remove the non-smp version of the kernel, but the list
of kernels to remove isn't clear, so I'm not sure if this is intended, or should
give a warning.

Comment 2 Need Real Name 2006-01-20 21:11:36 UTC
WFM

Comment 3 Need Real Name 2006-08-21 14:18:18 UTC
I think this works now. Mark as closed?


Note You need to log in before you can comment on or make changes to this bug.