Bug 174686 - system-config-display crashes when launching
system-config-display crashes when launching
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 09:06 EST by Jason
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 23:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-12-01 09:06:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
When I try to run system-config-display this is what I get.  I have a Number Nine Revolution IV video card and a SGI 1600sw LCD monitor.

/usr/share/system-config-display/xconf.py:32: DeprecationWarning: rhpl.monitor is deprecated; import rhpxl.monitor instead.
  import rhpl.monitor
/usr/share/system-config-display/xconf.py:33: DeprecationWarning: rhpl.videocard is deprecated; import rhpxl.videocard instead.
  import rhpl.videocard
/usr/share/system-config-display/xconf.py:35: DeprecationWarning: rhpl.mouse is deprecated; import rhpxl.mouse instead.
  import rhpl.mouse
/usr/share/system-config-display/xconf.py:37: DeprecationWarning: rhpl.xhwstate is deprecated; import rhpxl.xhwstate instead.
  from rhpl.xhwstate import *
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 311, in ?
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 215, in __init__
    self.init_from_xconfig(xconfig)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 337, in init_from_xconfig
    self.all_resolutions.sort (compare_resolution)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 59, in compare_resolution
    (w1, h1) = resolution_from_string(res1)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 49, in resolution_from_string
    return (string.atoi(w), string.atoi(h))
  File "/usr/lib/python2.4/string.py", line 403, in atoi
    return _int(s, base)
ValueError: invalid literal for int(): 512d08


Version-Release number of selected component (if applicable):
system-config-display-1.0.33-1

How reproducible:
Always

Steps to Reproduce:
1.  install system-config-display
2.  run it and see error
3.
  

Actual Results:  I see the traceback.

Expected Results:  system-config-display should run.

Additional info:
Comment 1 Jason 2006-01-04 10:24:10 EST
system-config-display still crashes with the above traceback in
system-config-display-1.0.33-1.1
Comment 2 Wade Mealing 2006-01-09 02:52:54 EST
Can you post your /etc/X11/xorg.conf file ?
Comment 3 Wade Mealing 2006-01-09 03:00:33 EST
I get a similar problem when there my xorg.conf is wrong... I get this..

    return (string.atoi(w), string.atoi(h))
  File "/usr/lib/python2.4/string.py", line 403, in atoi
    return _int(s, base)
ValueError: invalid literal for int(): d768

When my screen is

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1280x1024" "1152x864" "1152x768" "1024x768" "800x600"
"640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024xd768" "800x600" "640x480"
        EndSubSection
EndSection

Check your configuration file for typos if you have modified this file by hand.
 If you have not, it looks as though whatever generated this file is incorrect.
Comment 4 Jason 2006-01-09 09:11:18 EST
Here is the relavent portion of my xorg.conf.  It looks good to me.

Section "Modes" 

	Identifier "SGI" 

ModeLine "1600x1024d32" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 7
+Hsync +Vsync 

ModeLine "1600x1024d16" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 5
+Hsync +Vsync 

ModeLine "1600x1024d08" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 1
+Hsync +Vsync 

ModeLine "800x512d32" 54.375 800 800 840 848 512 512 514 515 HSkew 7 DoubleScan
+Hsync +Vsync 

ModeLine "800x512d16" 54.375 800 800 840 848 512 512 514 515 HSkew 5 DoubleScan
+Hsync +Vsync 

ModeLine "800x512d08" 54.375 800 800 840 848 512 512 514 515 HSkew 1 DoubleScan
+Hsync +Vsync 

EndSection 



Section "Monitor" 

	Identifier "Monitor0" 

	VendorName "Silicon Graphics" 

	ModelName "SGI 1600SW Flatpanel" 

	UseModes "SGI"

	HorizSync 31.5-110 

	VertRefresh 40-150 

        Option "dpms"

EndSection 



Section "Device" 

	Identifier "Card0" 

	Driver "i128" 

	VendorName "Number Nine" 

	BoardName "Imagine 128 Rev IV T2R4" 

EndSection 



Section "Screen" 

	Identifier "Screen0" 

	Device "Card0" 

	Monitor "Monitor0" 

	DefaultDepth 24 

	SubSection "Display" 

		Depth 08 

		Modes "800x512d08" 

	EndSubSection 

	SubSection "Display" 

		Depth 16 

		Modes "800x512d32" 

	EndSubSection 

	SubSection "Display" 

		Depth 24 

		Modes "800x512d32" 

	EndSubSection 

EndSection 
Comment 5 Jason 2006-01-14 21:46:59 EST
This is the traceback I get from system-config-display-1.0.35-1

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 311, in ?
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 231, in __init__
    self.init_from_xconfig(xconfig)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 353, in
init_from_xconfig
    self.all_resolutions.sort (compare_resolution)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 58, in
compare_resolution
    (w1, h1) = resolution_from_string(res1)
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 48, in
resolution_from_string
    return (string.atoi(w), string.atoi(h))
  File "/usr/lib/python2.4/string.py", line 403, in atoi
    return _int(s, base)
ValueError: invalid literal for int(): 512d08
Comment 6 Jason 2006-01-31 14:50:20 EST
In version system-config-display-1.0.36-1 it nolonger crashes, but it does not
run either.  The first time I run s-c-d ddcprobe runs forever and nothing else
happens.  If I ctrl-break out of s-c-d and kill -9 ddcprobe and then run s-c-d
again I get the same traceback as above.
Comment 7 Wade Mealing 2006-02-03 09:18:30 EST
system-config-display-1.0.33-1.1 here.. are you still getting it with this version ?
Comment 8 Jason 2006-02-03 10:40:13 EST
See comment #1.  1.0.33-1.1 is old.  I use system-config-display-1.0.36-1 from
rawhide.  I did a yum update yesterday but there was no newer version.  Todays
rawhide has not been released yet.  Did you perhaps mistype the version number?
Comment 9 Jeremy Katz 2006-02-14 14:52:19 EST
I can't reproduce this at all here, even with munging my xorg.conf.  As Wade
requested in comment #2, can you please attach your entire xorg.conf?
Comment 10 Chris Lumens 2006-02-14 14:58:35 EST
The problem here appears to be that nobody's taught rhpxl that anything besides
"NNNNxNNNN" is a valid name for a mode, most likely because all our tools
generate mode names that are just the resolution, and not anything extra.  I can
modify rhpxl to strip out extra stuff from the end of the horizontal/vertical
components of the assumed mode name, but in the general case we can't really
take every possible naming convention into account (except for throwing out
names we don't understand when we're sorting).
Comment 11 Jason 2006-02-15 07:44:22 EST
Section "ServerLayout"
	Identifier "XFree86 Configured"
	Screen 0 "Screen0" 0 0
	InputDevice "Mouse0" "CorePointer"
	InputDevice "Keyboard0" "CoreKeyboard"
EndSection
#Section "ServerFlags"
	# Option "EstimateSizesAggressively" "0"
#EndSection

Section "Files"
#  get rid of xfs
#        FontPath "unix/:7100"
EndSection 

Section "Module" 
        Load "dbe"
	Load "extmod" 
        Load "fbdevhw"
	Load "glx" 
	Load "record"
        Load "freetype"
        Load "type1" 
        Load "dri"
        Load "GLcore"
EndSection

Section "InputDevice"
	Identifier "Keyboard0"
	Driver "kbd"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier "Mouse0"
	Driver "mouse"
	Option "Protocol" "ExplorerPS/2"
	Option "Device" "/dev/input/mice"
        Option "Buttons" "5"
	Option "Emulate3Buttons" "no"
	Option "ZAxisMapping" "4 5" 
	Option "ButtonMapping" "1 2 3 6 7"
EndSection

Section "Modes"
	Identifier "SGI"
ModeLine "1600x1024d32" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 7
+Hsync +Vsync
ModeLine "1600x1024d16" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 5
+Hsync +Vsync
ModeLine "1600x1024d08" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 1
+Hsync +Vsync
ModeLine "800x512d32" 54.375 800 800 840 848 512 512 514 515 HSkew 7 DoubleScan
+Hsync +Vsync
ModeLine "800x512d16" 54.375 800 800 840 848 512 512 514 515 HSkew 5 DoubleScan
+Hsync +Vsync
ModeLine "800x512d08" 54.375 800 800 840 848 512 512 514 515 HSkew 1 DoubleScan
+Hsync +Vsync
EndSection

Section "Monitor"
	Identifier "Monitor0"
	VendorName "Silicon Graphics"
	ModelName "SGI 1600SW Flatpanel"
	UseModes "SGI"
	HorizSync 31.5-110 
	VertRefresh 40-150 
        Option "dpms"
EndSection

Section "Device"
	Identifier "Card0"
	Driver "i128"
	VendorName "Number Nine"
	BoardName "Imagine 128 Rev IV T2R4"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device "Card0"
	Monitor "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Depth 08
		Modes "800x512d08"
	EndSubSection
	SubSection "Display"
		Depth 16
		Modes "800x512d32"
	EndSubSection
	SubSection "Display"
		Depth 24
		Modes "800x512d32"
	EndSubSection
EndSection

I have to use the xorg.conf I created years ago because s-c-d does not list
800x512 or 1600x1024 as valid resolutions.  I opened
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174052 about this but since
s-c-d keeps crashing I don't know if any work has been on this issue.  I will
remove the modelines I don't use and switch to a NNNNxNNNN name style and post
the results.
Comment 12 Jason 2006-02-15 08:02:28 EST
I changed my xorg.conf to use NNNNxNNNN for the modeline names and now s-c-d is
working.

Thanks for the help,
Jason
Comment 13 Wade Mealing 2006-04-11 23:44:59 EDT
I think this should be fixed in FC5 final, closing now.

Note You need to log in before you can comment on or make changes to this bug.