Bug 174740 - ypserv starts before cupsd and can steal port
ypserv starts before cupsd and can steal port
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ypserv (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 15:35 EST by Bill Adams
Modified: 2015-01-07 19:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:50:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Adams 2005-12-01 15:35:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
After a reboot, cupsd would not start.  /var/log/cups/error_log said socket address already in use.  lsof showed ypbind listening on ipp port 631.

Workaround was:
service ypbind stop
service ypbind start
service cups start

Version-Release number of selected component (if applicable):
ypbind-1.12-5

How reproducible:
Couldn't Reproduce


Additional info:

The bug is that ypserv listens on a well-known port.
Comment 1 Bill Adams 2005-12-01 15:38:43 EST
Meant to say ypserv-2.8-6 
Comment 2 Bill Adams 2006-02-16 14:05:13 EST
I think this bug can be fixed in the ypserv rpm, so that ypserv starts after
cupsd, and any other root daemon.  AFAIK, ypserv binds INADDR_ANY, to any
available privileged port.
Comment 3 RHEL Product and Program Management 2007-10-19 14:50:20 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.
Comment 4 Bill Adams 2007-10-19 16:36:08 EDT
Have you determined that this bug does not exist in RHEL4?

Note You need to log in before you can comment on or make changes to this bug.