This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 174779 - up2date shows huge warning dialog when kde-i18n-Polish-3.4.2-0.fc4.1 is included in update list
up2date shows huge warning dialog when kde-i18n-Polish-3.4.2-0.fc4.1 is inclu...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
4
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 20:25 EST by Suhan Andrei
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 11:33:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Suhan Andrei 2005-12-01 20:25:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The "Warning" dialog is huge. we need here a scrolable widget to see complete warning. One need extremely high resolution to see such a message (1280x1024) is not enough.
Warning goes like :
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy dependencies:
Name                                    Version        Release
--------------------------------------------------------------
c-ares                                  1.3.0          1.fc4               
dietlibc-lib                            0.29           2.fc4               
eclipse-rcp                             3.1.1          1jpp_1fc.FC4.4      
fftw3                                   3.0.1          3                   
fftw3-devel                             3.0.1          3                   
gnet2                                   2.0.7          5.fc4               
gpgme                                   1.0.2          3.fc4               
gtkmathview                             0.7.5          2.fc4               
hdf5                                    1.6.4          4.fc4               
hdf5-devel                              1.6.4          4.fc4               
id3lib                                  3.8.3          11.fc4              
lapack-devel                            3.0            35.fc4              
link-grammar                            4.1.3          4.fc4               
lucene                                  1.4.3          1jpp_3fc            
lucene-demo                             1.4.3          1jpp_3fc            
mathml-fonts                            1.0            19.fc4              
portaudio                               18.1           5                   

file /usr/share/doc/HTML/pl/common/1.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/10.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/2.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/3.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/4.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/5.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/6.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/7.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/8.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/9.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/appheader.html conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/artistic-license.html conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/bottom-left.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/bottom-middle.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/bottom-right.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/bottom1.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1
file /usr/share/doc/HTML/pl/common/bottom2.png conflicts between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1
and kdelibs-3.4.2-0.fc4.1 ...." 

( I really could not paste whole mesage as I cant see more of it )

Version-Release number of selected component (if applicable):
up2date-4.4.23-4

How reproducible:
Always

Steps to Reproduce:
1.select kde-i18n-Polish-3.4.2-0.fc4.1 in installl list
2.
3.
  

Actual Results:  Huge dialog. Could not continue update/instalation.

Expected Results:  such kind of dialog shall have a scrolable area where to output message, if indeed the message is normal to appear like a dialog, or the message to be written in a log file and warning dialog to point to it.

Additional info:

Can workaround if kde-i18n-Polish-3.4.2-0.fc4.1, but what if one really needs it?
Comment 1 Chris Jones 2006-03-27 11:15:25 EST
The errors relating to kde-i18n-Polish can be found in #171870
Comment 2 Suhan Andrei 2006-03-28 01:03:38 EST
Still please consider enhancement for up2date gui as described in expected
results. In case huge message ocurs again for other reason(s), then up2date will
be able to present it all. 
Comment 3 John Thacker 2006-10-29 15:32:05 EST
up2date was replaced by pirut and put (package pirut) as of FC5.  Only FC5 and
FC6 are currently fully supported; FC3 and FC4 are supported for security fixes
only.  If this bug occurs in FC3 or FC4 and is a security bug, please change the
product to Fedora Extras and the version to match.  If you can verify that the
bug exists in RHEL as well, please change the product and version appropriately.

The codebase for pirut and pup is quite different, but if a similar bug exists
in pirut and pup in FC5 or FC6, please change the product to pirut and the
version appropriately and update the bug report.

We apologize that the bug was not fixed before now.  The status will be changed
to NEEDINFO, and if the bug is not updated with evidence that it is a security
bug or a bug that affects RHEL, it will be closed.
Comment 4 John Thacker 2006-11-05 11:33:08 EST
Closing per previous message.

Note You need to log in before you can comment on or make changes to this bug.