Bug 17479 - RAID1 umount fails at reboot
RAID1 umount fails at reboot
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
: 17481 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-13 18:28 EDT by Viraj Alankar
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 14:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viraj Alankar 2000-09-13 18:28:06 EDT
When rebooting our system, which has / as a md0 RAID1 device, we get:

Unmounting file
systems                                                         
Turning off RAID for md0 md: md0 still
mounted.                                 
/dev/md0: Device or resource
busy                                               
                                                                                
Unmounting proc file
system                                                     
Please stand by while rebooting the
system...                                   
stopping all md
devices.                                                        
marking sb
clean...                                                             
md: updating md0 RAID superblock on
device                                      
sdb3 [events: 0000001a](write) sdb3's sb offset:
8329600                        
sda3 [events: 0000001a](write) sda3's sb offset:
8329600                        
.                                                                               
md0 switched to read-only
mode.                                                 
Restarting system.                                         

Upon reboot, everything seems to mount correctly without any problems, so
I'm wondering if I should be worrying about the above error. My
/etc/raidtab:

raiddev            
/dev/md0                                                    
raid-level                 
1                                                   
nr-raid-disks              
2                                                   
chunk-size                 
64k                                                 
persistent-superblock      
1                                                   
#nr-spare-disks    
0                                                           
    device         
/dev/sda3                                                   
    raid-disk    
0                                                             
    device         
/dev/sdb3                                                   
    raid-disk     1             

Any help appreciated.

Viraj.
Comment 1 Viraj Alankar 2000-09-13 18:40:17 EDT
*** Bug 17481 has been marked as a duplicate of this bug. ***
Comment 2 Erik Troan 2000-09-19 13:15:36 EDT
Is md0 your root device? This definitely doesn't hurt anything btw.
Comment 3 Viraj Alankar 2000-09-19 14:19:30 EDT
Yes, md0 is /
Comment 4 Erik Troan 2000-09-29 12:24:41 EDT
We're fixing this bug in initscripts (turning off raid before shutting down used
to be necessary, but it's not anymore). It won't cause any problems, just ugly
messages.

Note You need to log in before you can comment on or make changes to this bug.