Bug 174854 - star doesn't archive ACLs on an ext3
star doesn't archive ACLs on an ext3
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: star (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-02 15:27 EST by Buck Huppmann
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-14 05:25:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Buck Huppmann 2005-12-02 15:27:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11) Gecko/20021120 Netscape/7.01

Description of problem:
on a filesystem that /etc/mtab says is mounted

    ext3 rw,acl,user_xattr

i

    star -c -H exustar -acl

a directory that contains files that have extended ACLs. when i

    star tvvf

the archive, i see no + signs. similarly, when i

    star -x -Hexustar -p -acl -f

the archive, no extended ACLs are in evidence on the extracted
directories and files

Version-Release number of selected component (if applicable):
star-1.5a08-4

How reproducible:
Always

Steps to Reproduce:
0. get root
1. star -c -H exustar -acl -f ARCHIVE DIRECTORY
2. a. star -t -v -f ARCHIVE
   or
   b. i. star -x -H exustar -p -acl -f ARCHIVE
     ii. ls -laR DIRECTORY

  

Actual Results:  no + signs and no ACLs in evidence

Expected Results:  + signs and ACLs should have littered the directory listing

Additional info:

Linux our.anonymous.host 2.4.21-37.ELsmp #1 SMP Wed Sep 7 13:28:55 EDT 2005 i686 i686 i386 GNU/Linux
libacl-2.2.3-1
libattr-2.2.0-1

if you can tell me an alternate utility that will save and restore extended ACLs
on ext3, besides dump, you can downgrade this
Comment 1 Peter Vrabec 2005-12-05 06:39:28 EST
I can't reproduce it.

[root@vepro tmp]# ll a
total 12
-rw-r--r--+   1 root     root           28 Dec  5 09:39 pokus
-rw-r--r--    1 root     root           55 Dec  5 11:28 xxx
[root@vepro tmp]# star -c -H exustar -acl a > b/foo.tar
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
[root@vepro tmp]# cd b
[root@vepro b]# star tvvf foo.tar
      0 drwxr-xr-x  root/root Dec  5 11:30 2005 a/
     28 -rw-r--r--+ root/root Dec  5 09:39 2005 a/pokus
     55 -rw-r--r--  root/root Dec  5 11:28 2005 a/xxx
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
[root@vepro b]# star -x -Hexustar -p -acl -f foo.tar
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
[root@vepro b]# ll a
total 12
-rw-r--r--+   1 root     root           28 Dec  5 09:39 pokus
-rw-r--r--    1 root     root           55 Dec  5 11:28 xxx

[root@vepro tmp]# rpm -q redhat-release
redhat-release-3AS-13.5.1
[root@vepro tmp]# rpm -q star
star-1.5a08-4
[root@vepro b]# uname -a
Linux vepro 2.4.21-32.ELsmp #1 SMP Fri Apr 15 21:03:28 EDT 2005 x86_64 x86_64
x86_64 GNU/Linux
Comment 2 Buck Huppmann 2005-12-05 08:16:07 EST
i'm sorry. it's a bit more exotic than i initially characterized. the only
circumstance in which i can get it to repeat is when i cook up some really
bizarre default ACL permissions:

[root@arclx1 star]# ls -ld ../test.d
drwxr-xr-x+   2 root     root         4096 Dec  5 07:57 ../test.d
[root@arclx1 star]# getfacl ../test.d
# file: ../test.d
# owner: root
# group: root
user::rwx
group::r-x
other::r-x
default:user::rwx
default:group::r--
default:other::r--

[root@arclx1 star]# star -c -Hexustar -f - -acl -C .. test.d | star tvvf -
      0 drwxr-xr-x  root/root Dec  5 07:57 2005 test.d/
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
[root@arclx1 star]# ^tvvf^-x -Hexustar -p -acl -f
star -c -Hexustar -f - -acl -C .. test.d | star -x -Hexustar -p -acl -f -
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
[root@arclx1 star]# ls -ld test.d
drwxr-xr-x    2 root     root         4096 Dec  5 07:57 test.d
[root@arclx1 star]# getfacl test.d
# file: test.d
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

[root@arclx1 star]#
Comment 3 Peter Vrabec 2005-12-07 04:29:03 EST
[root@vepro tmp]# getfacl a
# file: a
# owner: root
# group: root
user::rwx
group::r-x
other::r-x
default:user::rwx
default:group::r-x
default:mask::r-x
default:other::r-x

[root@vepro tmp]# star -c -H exustar -acl a > b/foo.tar
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
[root@vepro tmp]# star tvvf b/foo.tar
      0 drwxr-xr-x+ root/root Dec  5 11:30 2005 a/
     55 -rw-r--r--  root/root Dec  5 11:28 2005 a/xxx
     28 -rw-r--r--+ root/root Dec  5 09:39 2005 a/pokus
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
[root@vepro tmp]# cd b
[root@vepro b]# star -x -Hexustar -p -acl -f foo.tar
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).
[root@vepro b]# getfacl a/
# file: a
# owner: root
# group: root
user::rwx
group::r-x
other::r-x
default:user::rwx
default:group::r-x
default:mask::r-x
default:other::r-x

Note You need to log in before you can comment on or make changes to this bug.