Bug 174887 - Enable usb-storage support to Anaconda rescue
Enable usb-storage support to Anaconda rescue
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
: FutureFeature, Reopened
: 174888 174909 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-03 09:21 EST by Gilboa Davara
Modified: 2008-07-31 17:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 17:21:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (5.21 KB, text/plain)
2005-12-05 16:04 EST, Gilboa Davara
no flags Details
Linux rescue syslog (29.28 KB, text/plain)
2005-12-05 16:06 EST, Gilboa Davara
no flags Details
Anaconda boot kernel log (7.57 KB, text/plain)
2005-12-05 16:07 EST, Gilboa Davara
no flags Details
Pre-manual insmod system log. (i386/USB disk-on-key) (24.95 KB, text/plain)
2005-12-06 03:03 EST, Gilboa Davara
no flags Details
Post-manual insmod system log. (i386/USB disk-on-key) (25.78 KB, text/plain)
2005-12-06 03:04 EST, Gilboa Davara
no flags Details
Pre-manual insmod dmesg. (i386/USB disk-on-key) (7.55 KB, text/plain)
2005-12-06 03:04 EST, Gilboa Davara
no flags Details
Post-manual insmod dmesg. (i386/USB disk-on-key) (7.56 KB, text/plain)
2005-12-06 03:05 EST, Gilboa Davara
no flags Details
Anaconda log. (i386/USB disk-on-key) (4.85 KB, text/plain)
2005-12-06 03:06 EST, Gilboa Davara
no flags Details
Pre-manual insmod python log. (i386/USB disk-on-key) (1.09 KB, text/plain)
2005-12-06 03:07 EST, Gilboa Davara
no flags Details
Post-manual insmod python log. (i386/USB disk-on-key) (1.09 KB, text/plain)
2005-12-06 03:09 EST, Gilboa Davara
no flags Details

  None (edit)
Description Gilboa Davara 2005-12-03 09:21:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
I'm trying to recover a dead FC4 install from an external USB2 drive.
Anaconda, while detecting the USB device, fails to load the usb-stroage module, and there is no manual way of doing it, (Even in expert and or dd mode)

More-ever, Anaconda sourly a tool that will enable user to manually select/start drivers during the rescue/install procedure.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect an external USB drive
2. Reboot using Fedora disk 1
3. Select "linux rescue" and/or "linux".


  

Actual Results:  External USB drive is not detected. usb-storage module not loaded and cannot be manually loaded.

Expected Results:  External USB drive should be detected during the "hardware-probe" stage.

Additional info:
Comment 1 Rahul Sundaram 2005-12-03 09:37:15 EST
Thank you for the report. Moving this to devel since this isnt specific to FC4
as such.
Comment 2 Rahul Sundaram 2005-12-03 09:38:11 EST
*** Bug 174888 has been marked as a duplicate of this bug. ***
Comment 3 Gilboa Davara 2005-12-04 04:14:20 EST
Opps... yet another duplicate:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174909
I had severe case of FF timing out. Guess it didn't :(

Sorry...
Comment 4 Jeremy Katz 2005-12-05 11:06:31 EST
*** Bug 174909 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2005-12-05 11:09:57 EST
usb-storage is loaded, but we don't list USB storage devices with
probe-harddrives as it gives identical results to using the installer (where we
also don't support installing to USB hard drives)
Comment 6 Gilboa Davara 2005-12-05 14:48:40 EST
OK.
After looking into the modules.cgz file, I can see that usb-storage is indeed there.
What I don't understand is, when "linux rescue" is invoked, why doesn't the
external USB device get scanned? 
AFAIK (by lsmod) usb-storage isn't loaded (in rescue mode), and opening the
initrd image, followed by the modules.cgz just to extract the usb-storage by
hand, strikes me as odd...

Why no enable manual loading of drivers (usb-storage in this case) during rescue
mode?

Cheers,
Comment 7 Gilboa Davara 2005-12-05 14:50:18 EST
(Sorry for reopening the bug...)
Comment 8 Jeremy Katz 2005-12-05 15:33:24 EST
The module should be loaded -- if you look in /tmp/anaconda.log and/or
/tmp/syslog you should see any errors from it being loaded.
Comment 9 Gilboa Davara 2005-12-05 16:04:42 EST
Created attachment 121865 [details]
Anaconda log

AFAICS usb-storage isn't loaded.
(Generated by boot from DVD with "linux rescue" command line)
Comment 10 Gilboa Davara 2005-12-05 16:06:16 EST
Created attachment 121866 [details]
Linux rescue syslog

(Generated by boot from x86-64 DVD with "linux rescue" command line)
Comment 11 Gilboa Davara 2005-12-05 16:07:23 EST
Created attachment 121868 [details]
Anaconda boot kernel log

(Generated by boot from x86-64 DVD with "linux rescue" command line)
Comment 12 Jeremy Katz 2005-12-05 16:30:03 EST
Hmm, it doesn't look like kudzu is finding anything which uses usb-storage and
thus we're not loading it.

What's the output of 
python -c 'import kudzu; print kudzu.probe(kudzu.CLASS_UNSPEC, kudzu.BUS_USB,
kudzu.PROBE_ALL)'
Comment 13 Gilboa Davara 2005-12-06 03:00:50 EST
OK. I cannot reboot my primary machine, so I switching to my secondary (i386)
machine and used a 512MB disk-on-key.
See attached files.

I've copied the first batch of logs.
Manually extracted and inserted the usb-storage.ko and sg.ko modules.
Generated the second batch of logs.
Comment 14 Gilboa Davara 2005-12-06 03:03:41 EST
Created attachment 121890 [details]
Pre-manual insmod system log. (i386/USB disk-on-key)
Comment 15 Gilboa Davara 2005-12-06 03:04:19 EST
Created attachment 121891 [details]
Post-manual insmod system log. (i386/USB disk-on-key)
Comment 16 Gilboa Davara 2005-12-06 03:04:53 EST
Created attachment 121892 [details]
Pre-manual insmod dmesg. (i386/USB disk-on-key)
Comment 17 Gilboa Davara 2005-12-06 03:05:41 EST
Created attachment 121893 [details]
Post-manual insmod dmesg. (i386/USB disk-on-key)
Comment 18 Gilboa Davara 2005-12-06 03:06:43 EST
Created attachment 121894 [details]
Anaconda log. (i386/USB disk-on-key)
Comment 19 Gilboa Davara 2005-12-06 03:07:45 EST
Created attachment 121895 [details]
Pre-manual insmod python log. (i386/USB disk-on-key)
Comment 20 Gilboa Davara 2005-12-06 03:09:32 EST
Created attachment 121896 [details]
Post-manual insmod python log. (i386/USB disk-on-key)

AFACS, Kudzu, even with usb-storage and sg, doesn't 'see' the USB disk on key.
Comment 21 Jeremy Katz 2006-01-31 15:43:36 EST
This should be fixed now
Comment 22 Gilboa Davara 2006-04-07 11:17:05 EDT
Doesn't work.
FC5 rescue (x86_64)
Anaconda doesn't load the usb-storage module.
Comment 23 Red Hat Bugzilla 2007-02-05 14:18:05 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 24 Jeremy Katz 2007-02-05 15:55:42 EST
Does this still happen with FC6?
Comment 25 Gilboa Davara 2007-02-13 10:03:25 EST
No go.
Anaconda doesn't detect the USB storage device; usb-storage isn't loaded.
F7-test1-desktop
Comment 26 Michel Alexandre Salim 2007-02-23 10:57:57 EST
Happens to me too -- the problem is common between Anaconda and the installed
system; on the latter, I'd have to modprobe usb_storage manually.

Note that on FC6, both Anaconda and the installed system initializes usb_storage
properly.

Relevant lines from dmesg; it seems that libusual is indeed trying to load
usb-storage, but could not find it (not in initrd?) -- right now I'm resorting
to manually loading usb-storage

usb 3-3.4: new high speed USB device using ehci_hcd and address 6
usb 3-3.4: configuration #1 chosen from 1 choice
libusual: modprobe for usb-storage succeeded, but module is not present
input: Western Digital External HDD as /class/input/input5
input: USB HID v1.11 Device [Western Digital External HDD] on usb-0000:00:13.2-3
.4


(Harald located the problem -- initrd does not contain usb_storage)
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=204396
Comment 27 Gilboa Davara 2008-03-06 07:29:19 EST
I've hit the same problem with F8/x86_64 in rescue mode.
I had to manually unpack the initrd.img and modules.cgz files in-order to unpack
and load missing modules.

It seems that if fail to connect the USB disk during the initialization, the
usb-storage will be rmmod.

Shouldn't usb-strage and sg loaded by default when rescue mode is selected?

- Gilboa
Comment 28 Chris Lumens 2008-07-31 17:21:45 EDT
Under rescue mode in Rawhide, booting with both a USB disk attached and booting
with one attached after anaconda has run, it works as expected both times.  The
appropriate modules are loaded, the device nodes are created, and the
filesystems are mountable.  No need to do any initrd unpacking or module loading
yourself.

Note You need to log in before you can comment on or make changes to this bug.