Bug 174908 - glibc-kernheaders missing radeonfb.h
glibc-kernheaders missing radeonfb.h
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-03 16:22 EST by Jesse Barnes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 15:56:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Barnes 2005-12-03 16:22:00 EST
I pulled down the latest pbbuttonsd src rpm and tried to build it, but I got 
this error: 
 
make[2]: Entering directory 
`/home/jbarnes/working/rpmbuild/BUILD/pbbuttonsd-0.7.2/src' 
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../intl -I../libpbbipc  
-include /usr/include/linux/cdrom.h 
-I/lib/modules/2.6.14-1.1735_FC5/build/include   -O2 -g -fsigned-char -c 
module_display.c 
module_display.c:30:28: error: linux/radeonfb.h: No such file or directory 
module_display.c: In function ‘display_switchmirror’: 
module_display.c:793: error: ‘FBIO_RADEON_GET_MIRROR’ undeclared (first use in 
this function) 
module_display.c:793: error: (Each undeclared identifier is reported only once 
module_display.c:793: error: for each function it appears in.) 
module_display.c:794: error: ‘ATY_RADEON_CRT_ON’ undeclared (first use in this 
function) 
module_display.c:795: error: ‘FBIO_RADEON_SET_MIRROR’ undeclared (first use in 
this function) 
 
It looks like glibc-kernheaders doesn't include the fb development headers, in 
this case radeonfb.h.  Shouldn't it be part of this package?
Comment 1 Jesse Barnes 2006-11-27 15:56:25 EST
FC6 kernel header packages seem to fix this bug.

Note You need to log in before you can comment on or make changes to this bug.