Bug 17491 - Exception Occurred in the RHL6.2 Installer for Alpha
Exception Occurred in the RHL6.2 Installer for Alpha
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
alpha Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-14 00:59 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-12 09:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-14 00:59:59 EDT
I was having trouble when starting up the GUI installation program. It seemed to boot directly into the GUI installation, but from there it 
seems to freeze up. The mouse cursor remains in the middle of the screen?

I replaced the Powerstorm video card with a S3 Trio64. Using the text install, all the packages seem to be installed ok, but then for some 
reason the program aborts abnormally.
Here's the error message (in detail) I get:

Exception Occured;

Trace back (innermost last):
File "/usr/bin/anaconda", line
342 in?
intf.run(todo, test=test)
File "/usr/bin/anaconda/text.py",
line 1165, in run
    rc=apply (Step[1] ( ), Step[2] )
File "/usr/lib/anaconda/text.py
line 702, in_ _call_ _
    if todo.doInstall ( ):
File "/usr/lib/anaconda/todo.py
line 1252, in doInstall
    Self.writeConfiguration ( )

Could it be possible that the CD iso image I downloaded from Redhat be corrupted?? How can I get around this problem??
Comment 1 Michael Fulbright 2000-09-14 15:02:43 EDT
Brock have you heard of this problem on the alpha, or is it most likely a CDROM
issue in your opinion?
Comment 2 Brock Organ 2000-09-14 18:57:56 EDT
could you give more detailed information on your hardware configuration ...? We
have not seen this issue here in our test lab ... :(

Specifically,

make
model
cpuinfo
meminfo
hard drive info

We will then try to reproduce this problem with the closest hardware we have ...
Comment 3 Need Real Name 2000-09-14 21:12:48 EDT
Make: Compaq
Model: Digital Alpha 500au Personal Workstation (Compaq branded)
CPU info: 500MHz Alpha 21164
Memory: 128 Meg ECC SDRAM
Hard drive: Quantum 4.3 Gig IDE
CD-ROM: AOpen 40X IDE

Any other info that you require please let me know :)

Thanks
Comment 4 Need Real Name 2000-09-20 01:33:46 EDT
I also have two ethernet devices, one that is built into the motherboard, and the other in a PCI slot.
Over the weekend, I used another brand of IDE CD-ROM, a Creative 48X to install Redhat. This time I was able to move the mouse cursor for a few 
seconds before the white screen appears, and everything comes to a halt. Similiar problem as before. I didn't try the text version of the install as I 
assume it will come up with the exception occurred message.
Comment 5 Need Real Name 2000-09-20 01:40:09 EDT
Removed the PCI ethernet card, and tried again. Installer still freezes up at the white screen...
Comment 6 Brock Organ 2000-09-25 14:59:00 EDT
hmmm ... I am unable to reproduce this problem in our test lab with similar
machines (500au miata workstations)...
Comment 7 Brock Organ 2000-09-25 15:00:54 EDT
Here is the hardware config of one of our test 500au workstations (miata):

00:03.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev
30)
00:04.0 IDE interface: CMD Technology Inc PCI0646 (rev 01)                      
00:07.0 Non-VGA unclassified device: Intel Corporation 82378IB [SIO ISA Bridge]
(rev 43)
00:14.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 02)        
01:09.0 SCSI storage controller: Q Logic ISP1020 (rev 05)                       
01:0a.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2064W [Millennium]
(rev 01)
Comment 8 Need Real Name 2000-09-26 00:17:58 EDT
hmmm...  Your system setup seems to be almost the same except for the Matrox Graphics Video card. Perhaps it may be the drivers for the S3 video 
card that is causing the GUI freeze ups? I will give the experimenting with removing/changing around devices, etc a go. But I am no pro with Alpha 
Workstations since this is the first machine of this type of architecture I have got my hands on :o)
I have installed RHL 6.2 (using the i386 version of course) on an Intel machine with no problems...
Will get back to you if I come up with a solution.
Comment 9 Need Real Name 2000-09-26 00:38:36 EDT
By the way could you explain what that exception occurred error may mean so in a sense I know what I should be trying to change, etc...

Thanks
Comment 10 Michael Fulbright 2000-09-29 12:55:06 EDT
Is there is more to the traceback than you have reported - the function at the
end of it just calls
other functions, which is where I would suspect it is dying.
Comment 11 Michael Fulbright 2000-09-29 12:55:50 EDT
I would recommend making another CD image from a fresh download of the ISO.

Be sure to check the md5sums so you know you got a good download.
Comment 12 Need Real Name 2000-09-30 04:09:57 EDT
No there isn't anymore of the traceback error... I've reported everything that was displayed. I will try a fresh download of the ISO image. 
How do I check the md5sums after I've downloaded?

Here is a summary of what I am doing:
* To start the install, I've created a boot disk using rawrite and dumping the gemeric.img onto floppy.
* At the SRM console I am typing boot dva0 -fi 0
* Then I get to the aboot> prompt, saying that image could not be found.
* I type in vmlinux.gz root=/dev/hdb and the kernel loads (trys to load the GUI install) or add text to load the text installer


As the installer is loading/initialising devices, etc, I saw a message saying that the kernel was trying to "remount root read write Failed (but that's ok)"

Is there anything that I may be doing wrong?
Comment 13 Need Real Name 2000-09-30 04:10:18 EDT
No there isn't anymore of the traceback error... I've reported everything that was displayed. I will try a fresh download of the ISO image. 
How do I check the md5sums after I've downloaded?

Here is a summary of what I am doing:
* To start the install, I've created a boot disk using rawrite and dumping the gemeric.img onto floppy.
* At the SRM console I am typing boot dva0 -fi 0
* Then I get to the aboot> prompt, saying that image could not be found.
* I type in vmlinux.gz root=/dev/hdb and the kernel loads (trys to load the GUI install) or add text to load the text installer


As the installer is loading/initialising devices, etc, I saw a message saying that the kernel was trying to "remount root read write Failed (but that's ok)"

Is there anything that I may be doing wrong?
Comment 14 Need Real Name 2000-10-04 21:44:15 EDT
Ok I got another copy of the Redhat Linux 6.2 Alpha CD, The exception occur errors I was getting in the text installer are probably due to a corrupt ISO 
image I downloaded. But however the first part of the Bug I reported, that being the GUI installation freezing up still occurs. After fully installing Redhat 
Linux using the text installer I try to load X Windows, the computer freezes up shortly after graphics have initialised... I suspect this may be due to a S3 
video card and Alpha incompatibility.
Comment 15 Michael Fulbright 2000-10-24 12:51:00 EDT
Moving to XFree86 component.
Comment 16 Mike A. Harris 2001-03-13 22:45:50 EST
S3 cards don't seem to be the best supported in Linux.  I also believe
that the virge and trio64 cards have hardware bugs that cause lockups, at
least that is what I've been told when I used to own one.  My recommendation
is to try out our latest Rawhide packages for XFree86 and see if they
solve the problem for you.  Much work has occured in XFree86 since you've had
problems with it.
Comment 17 Mike A. Harris 2001-05-12 09:13:13 EDT
I do not have the hardware to do anything about this.  It's something
the XFree86 team will have to fix if it still persists in the current
XFree86 code.  S3 hardware is not easy to come by, not to mention there
are infinite variations and hardware bugs in these cards.

Best bet: Get a new video card that is supported well.  ie: ATI Radeon or r128
Comment 18 Need Real Name 2001-05-14 00:00:55 EDT
It's been a long time since I have had this little problem solved (or worked around it), shelved and is probably now collecting dust. I have since replaced 
(and sold off) that S3 video card with a Matrox Millenium II with 8MB video RAM. I did manage to get RHL 6.2 installed and running with the Matrox card. I 
am now running RHL 7.0 and intending to get 7.1 soon... I think that if I used that S3 v/c in an Intel machine it would have worked fine. It probably didn't 
work because, as I have read, that only a subset of hardware that is compatible with Intel machines will work with Alpha based machines and most likely 
if there is a bug in that piece of hardware the Alpha will most likely pick it up. As I have found out it causes a lockup when the installion GUI tries to 
load... 

If anyone out there comes across this, having a similar problem with their S3 v/c and Alpha machine, I'd strongly recommend you get some sort of 
Matrox video card. Preferably a Matrox Millenium I or II. The one I got was pulled out of a second-hand Compaq branded Intel PC. Since Compaq now 
owns the intellectual property of DEC, the makers of Alpha RISC architecture, they should work nicely with your Alpha when trying to install RHL Linux or 
X-Windows :)

Reece

Note You need to log in before you can comment on or make changes to this bug.