Bug 174929 - Turn off lib-foo-bar class loading to speed up Eclipse startup
Turn off lib-foo-bar class loading to speed up Eclipse startup
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Igor Foox
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 08:22 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 11:13:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2005-12-04 08:22:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Set the gnu.gcj.runtime.VMClassLoader.library_control property to "never" and you'll see that Eclipse starts up a little faster (15-20 seconds for me).  

See this thread:
https://www.redhat.com/archives/fedora-devel-java-list/2005-December/msg00000.html



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Modify the eclipse startup script by adding -Dgnu.gcj.runtime.VMClassLoader.library_control=never
2.Start eclipse
3.
  

Additional info:
Comment 1 Andrew Overholt 2005-12-04 10:04:55 EST
What are we going to do when we get rid of the wrapper script?
Comment 2 Anthony Green 2005-12-04 11:06:58 EST
(In reply to comment #1)
> What are we going to do when we get rid of the wrapper script?

There's also a corresponding GCC bug report for changing the default in libgcj.

See http://gcc.gnu.org/bugzilla/show_bug.cgi?id=25250

..but I don't know when that may happen.


Were you planning on removing the script prior to FC5?

Comment 3 Andrew Overholt 2005-12-04 12:56:14 EST
(In reply to comment #2)
> 
> Were you planning on removing the script prior to FC5?

Hopefully, yes.  See bug 168726.

Comment 4 Andrew Overholt 2005-12-05 11:30:37 EST
I guess I could put this into the forthcoming FC4 update.
Comment 5 Andrew Overholt 2005-12-05 11:36:15 EST
Igor, can you look at this before we do an FC4 update, please?
Comment 6 Andrew Overholt 2006-02-03 11:13:36 EST
Since we have no wrapper in FC4 either, this isn't going to happen until it's
the gcj default.
Comment 7 Anthony Green 2006-02-03 11:37:01 EST
(In reply to comment #6)
> Since we have no wrapper in FC4 either, this isn't going to happen until it's
> the gcj default.

Well, there's actually a wrapper executable (the /usr/lib/eclipse/eclipse).  You
should be able to simply set that property in that program, no?

Note You need to log in before you can comment on or make changes to this bug.