Bug 174935 - iproute does not work on aliase
iproute does not work on aliase
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 10:15 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 02:49:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-12-04 10:15:02 EST
I have two IP for eth0 which correspond to eth0 and eth0:1
I want to create a route 
to 192.168.66.0/24 via 192.168.0.50 from eth0:1 
system-config-network allows this to do just fine.
But when ifup-routes is exacuted I get this error from /sbin/ip for eth0:1


 /sbin/ip route add 192.168.66.0/24 via 192.168.0.50   dev eth0:1
Cannot find device "eth0:1"

Putting exectly the samne settings to eth0 (using same tool system-network-config)
everything is OK 
 /sbin/ip route add 192.168.66.0/24 via 192.168.0.50   dev eth0

There should be no difference between eth0 and eth0:1
as both are an interface.
This look like /sbin/ip limitation.
Comment 1 Radek Vokal 2005-12-05 02:49:18 EST
Tested with rawhide iproute-2.6.14-8

root@garfield ~# ifup eth0:1
root@garfield ~# echo $?
0

root@garfield ~# ip route add 192.168.66.0/24 via 192.168.1.2   dev eth0:1
root@garfield ~# echo $?
0

root@garfield ~# ip route list dev eth0:1
..
192.168.66.0/24 via 192.168.1.2
..
..

Seems to me it's already fixed.
Comment 2 Need Real Name 2005-12-05 03:44:56 EST
Yes. Upgrade to iproute-2.6.14-9 fixed the problem
Comment 3 Need Real Name 2005-12-05 03:56:09 EST
The only thing which seems does not work right - when I connect 
to 192.168.66.0/24 network in connects still using the IP of eth0 ,
not the IP of eth0:1 as one would expect from 
ip route add 192.168.66.0/24 via 192.168.1.2   dev eth0:1
This looks like a bug to me.
Comment 4 Radek Vokal 2005-12-05 05:00:22 EST
hmm, I'm right now not sure what's the correct behavior here
also ip route list dev eth0 and dev eth0:1 show same output which is really
misleading to me ..

Anyway, you can specify the source adress with

ip route add 192.168.66.0/24 via 192.168.1.2 src {The_Source_IP_of_interface}

Note You need to log in before you can comment on or make changes to this bug.