Bug 174946 - latest device-mapper requires older version of itself, breaks yum
latest device-mapper requires older version of itself, breaks yum
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 14:27 EST by Denis Leroy
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-04 14:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2005-12-04 14:27:00 EST
The latest version of device-mapper (1.02.02-1) has a build problem: the
addition of --enable-dmeventd causes the resulting package to depends on both
the old and new version of itself, which of course breaks yum update :

> rpm -qp --requires rpmbuild/RPMS/i386/device-mapper-1.02.02-1.i386.rpm
[cut]
libdevmapper.so.1.01
libdevmapper.so.1.01(Base)
libdevmapper.so.1.02
libdevmapper.so.1.02(Base)
[cut]


Maybe the package needs to be split in two ?
Comment 1 Warren Togami 2005-12-04 14:37:53 EST
It looks like pjones fixed this in device-mapper-1.02.02-2.
Comment 2 Peter Jones 2005-12-04 14:38:57 EST
Yeah, this is fixed.

Note You need to log in before you can comment on or make changes to this bug.