Bug 174962 - Broken .spec file
Broken .spec file
Status: CLOSED DUPLICATE of bug 184597
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Depends On:
  Show dependency treegraph
Reported: 2005-12-04 22:09 EST by Carlo Wood
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-03 04:43:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carlo Wood 2005-12-04 22:09:42 EST
Description of problem:

rpmbuild errors out.

Version-Release number of selected component (if applicable):


How reproducible:

rpm -i elfutils-0.108-1.src.rpm
rpmbuild -ba elfutils.spec

Actual results:

Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/elfutils-root
error: Installed (but unpackaged) file(s) found:

RPM build errors:
    Installed (but unpackaged) file(s) found:

Expected results:

Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/elfutils-root
Wrote: /usr/src/redhat/SRPMS/elfutils-0.108-1.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/elfutils-0.108-1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/elfutils-devel-0.108-1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/elfutils-libelf-0.108-1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/elfutils-libelf-devel-0.108-1.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.20799
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd elfutils-0.108
+ rm -rf /var/tmp/elfutils-root
+ exit 0

Additional info:

I fixed this by changing the .spec file and
changing the line:

  rm -f .%{_libdir}/libasm-%{version}.so


  rm -f .%{_libdir}/libasm*.so*

(where it says 'Nuke unpackaged files')
Comment 1 Roland McGrath 2006-04-03 04:43:22 EDT

*** This bug has been marked as a duplicate of 184597 ***
Comment 2 Carlo Wood 2006-04-03 10:33:45 EDT
I wonder how this can be a 'duplicate' of 184597 when
this bug report was reported three months BEFORE that one.
I'd think it's the other way around.

Note You need to log in before you can comment on or make changes to this bug.