Bug 175005 - xsane can't find usb scanner
xsane can't find usb scanner
Status: CLOSED DUPLICATE of bug 183063
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 13:19 EST by Takaki Hiroshi
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-05 12:13:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Takaki Hiroshi 2005-12-05 13:19:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.12) Gecko/20051018 Fedora/1.7.12-2

Description of problem:
xsane can't find usb scanner. Root user can it. I think the following file owner is wrong.

# ls -l /proc/bus/usb/001/004
-rw-r--r-- 1 root root 50 12$B7n(B  6 00:55 /proc/bus/usb/001/004

This file owner is console login user in FC4. 

And, the following symlink isn't exists.

# ls -l /dev/scanner-usb-\:proc\:bus\:usb\:001\:004
lrwxrwxrwx  1 root root 21 12$B7n(B  6  2005 /dev/scanner-usb-:proc:bus:usb:001:004 -> /proc/bus/usb/001/004

This symlink is exists in FC4.

Version-Release number of selected component (if applicable):
udev-075-4

How reproducible:
Always

Steps to Reproduce:
1. login with user. (not root user)
2. open gnome-terminal
3. type 'xsane &'

Actual Results:  can't start xsane.

Expected Results:  start xsane.

Additional info:

kernel-2.6.14-1.1729_FC5
udev-075-4
hotplug-2004_09_23-10

$ sudo scanimage -L
device `epson:libusb:001:004' is a Epson GT-9700 flatbed scanner

$ /sbin/lsusb
Bus 001 Device 004: ID 04b8:0112 Seiko Epson Corp. Perfection 2450
Comment 2 Rahul Sundaram 2006-02-20 05:39:02 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Takaki Hiroshi 2006-03-05 12:13:26 EST

*** This bug has been marked as a duplicate of 183063 ***

Note You need to log in before you can comment on or make changes to this bug.