Bug 175010 - clusvcadm does not support locking
clusvcadm does not support locking
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
: 175009 185679 (view as bug list)
Depends On:
Blocks: 180185
  Show dependency treegraph
 
Reported: 2005-12-05 13:34 EST by danwest
Modified: 2009-04-16 16:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0557
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description danwest 2005-12-05 13:34:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
clusvcadm does not support locking of cluster's service managers:

clusvcadm -l    (lock services)
clusvcadm -S    (display lock status of each service manager)
clusvcadm -u    (unlock services)

  This feature is important for maintenance and cluster-wide shutdowns.  The manpage of clusvcadm does include a reference to the feature (probably left over from the RHEL3 product).

Version-Release number of selected component (if applicable):
rgmanager-1.9.39-0

How reproducible:
Always

Steps to Reproduce:
1. Run "clusvcadm -l", "clusvcamd -S", or "clusvcadm -u"
2. Run "man clusvcadm"
3.
  

Actual Results:  feature not implemented

Expected Results:  services would become node-locked.

Additional info:

feature was supported in RHEL3 cluster product
Comment 1 danwest 2005-12-06 09:16:11 EST
*** Bug 175009 has been marked as a duplicate of this bug. ***
Comment 2 Lon Hohberger 2006-02-07 15:11:16 EST
Side note - on RHCS3, this only caused locking to occur on the node where it was
run to prevent transitions after node events.  The RHCS4 version would be the same.
Comment 3 Lon Hohberger 2006-02-08 11:19:51 EST
This is not as simple on RHEL3 because of the forwarding threads -- but I have a
solution mostly done.  I'll post a patch after I test on more than one node. ;)
Comment 4 Lon Hohberger 2006-02-08 13:22:13 EST
On a second look, I can use VF to write data so that this causes a global
lockdown of services.

Note that this will differ slightly from the RHCS3 implementation:  Services
will be prevented from *starting* rather than completely locked in place.  So,
after running "clusvcadm -l", you will simply be able to run "service rgmanager
stop" on all nodes and no improper failover events will be triggered.

Note that, like the RHCS3 implementation, nodes (instances of rgmanager, really)
coming online after the lockdown has been issued will be unaware of the
lockdown.  Since this feature is only for preventing failover during a total
cluster shutdown, this particular behavior is not worth fixing.


Comment 5 Lon Hohberger 2006-03-20 15:59:12 EST
*** Bug 185679 has been marked as a duplicate of this bug. ***
Comment 10 Red Hat Bugzilla 2006-08-10 17:20:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0557.html

Note You need to log in before you can comment on or make changes to this bug.