Bug 175053 - The BUILD_BOMB is on by default
The BUILD_BOMB is on by default
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
 
Reported: 2005-12-05 20:00 EST by Rich Megginson
Modified: 2015-12-07 12:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:05:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
files for fix (74 bytes, text/plain)
2005-12-07 16:07 EST, Rich Megginson
no flags Details
diffs for fix (5.92 KB, text/plain)
2005-12-07 16:07 EST, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2005-12-05 20:00:38 EST
The server stops working after 120 days if you build it from source.  You must
use BUILD_BOMB="" PUMPKIN_AGE=0 on the command line to disable the build bomb. 
The current FDS 1.0 binaries were built this way and must be rebuilt.
Comment 1 Rich Megginson 2005-12-07 16:07:29 EST
Created attachment 122003 [details]
files for fix
Comment 2 Rich Megginson 2005-12-07 16:07:50 EST
Created attachment 122004 [details]
diffs for fix
Comment 3 Rich Megginson 2005-12-07 16:23:04 EST
Checking in ldapserver/Makefile;
/cvs/dirsec/ldapserver/Makefile,v  <--  Makefile
new revision: 1.29; previous revision: 1.28
done
Checking in ldapserver/internal_comp_deps.mk;
/cvs/dirsec/ldapserver/internal_comp_deps.mk,v  <--  internal_comp_deps.mk
new revision: 1.33; previous revision: 1.32
done
Checking in ldapserver/nsdefs.mk;
/cvs/dirsec/ldapserver/nsdefs.mk,v  <--  nsdefs.mk
new revision: 1.16; previous revision: 1.15
done
Comment 4 Nathan Kinder 2007-12-20 13:17:12 EST
This fix no longer applies since we've scrapped the old Makefiles and moved to
autoconf and automake.  There is no longer any sort of build bomb.

Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.