Bug 175054 - Unable to load sk98lin module
Unable to load sk98lin module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 20:06 EST by James C. Bevier
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.14-1.1644_FC4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 12:53:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James C. Bevier 2005-12-05 20:06:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
Kernel 1637 and 1644 will not recognize the D-Link DGE-530T Gigibyte controller.  Version 2.6.13-1532_FC4 and previous version work fine.  Linux does not recognize the device.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1637_FC4

How reproducible:
Always

Steps to Reproduce:
1.Boot system with kernel 1637 or later when using DGE-530T Gigibit controller
2.
3.
  

Actual Results:  Device is not recognized.  System can not talk to local gigibit ethernet network.

Expected Results:  Network card should work and be recognized by Linux.

Additional info:
Comment 1 Dave Jones 2005-12-06 18:10:25 EST
does the sgke driver work better ?
Comment 2 John W. Linville 2005-12-07 09:51:46 EST
I'm guess it won't...you probably need the sky2 driver.  It is available in 
the Fedora-netdev kernels: 
 
   http://people.redhat.com/linville/kernels/fedora-netdev/ 
 
Please give those a try and post the results here...thanks! 
Comment 3 James C. Bevier 2005-12-07 12:46:29 EST
I have tried the skge (not sgke) driver and it seemd to work fine with the 
1644 kernel.  I have not tried the kernel from fedora-netdev because this 
system is a production system.  I may try it at some later date if I get a 
chance.
Comment 4 John W. Linville 2005-12-07 12:53:50 EST
Ah, well...ignore comment 2... :-) 
 
Sounds like things are working for you now. 

Note You need to log in before you can comment on or make changes to this bug.