Bug 175103 - segfault in libclearlooks.so when clicking calendar icon in evolution
segfault in libclearlooks.so when clicking calendar icon in evolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2-engines (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 175057 175417 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-06 12:45 EST by James Laska
Modified: 2013-09-02 02:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-11 01:07:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace with *many* -debuginfo rpms installed (8.06 KB, text/plain)
2005-12-06 14:29 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2005-12-06 12:45:57 EST
# RPMS evolution-2.4.2-2.i386, gtk2-engines-2.7.0-1.i386

My up2date rawhide system crashes now when clicking on the calendar icon in
evolution.  Additionally, the calendar on the gnome-panel does not display when
I click the clock.

Steps to reproduce:
 1) gdb 
 2) attach 2872 (evolution pid)
 3) on evolution, click calendar icon

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208296752 (LWP 2872)]
0x0031de59 in clearlooks_rc_style_register_type () from
/usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so
(gdb) bt
#0  0x0031de59 in clearlooks_rc_style_register_type () from
/usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so
#1  0x0031dfdf in clearlooks_rc_style_register_type () from
/usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so
#2  0x070496ce in gtk_paint_shadow () from /usr/lib/libgtk-x11-2.0.so.0
#3  0x06702b3f in e_calendar_item_draw (canvas_item=0xa3a75d0,
drawable=0xa6f4090, x=0, y=0, width=292, height=150)
    at e-calendar-item.c:917
#4  0x00d1325c in gnome_canvas_item_request_update () from
/usr/lib/libgnomecanvas-2.so.0
#5  0x00d18f80 in gnome_canvas_item_new () from /usr/lib/libgnomecanvas-2.so.0
#6  0x06fef170 in gtk_marshal_VOID__UINT_STRING () from /usr/lib/libgtk-x11-2.0.so.0
#7  0x0019a605 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#8  0x0019ac38 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#9  0x001aacee in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#10 0x001abe16 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#11 0x001ac409 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#12 0x070d10cf in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x00d174de in gnome_canvas_item_move () from /usr/lib/libgnomecanvas-2.so.0
#14 0x00d1758f in gnome_canvas_item_move () from /usr/lib/libgnomecanvas-2.so.0
#15 0x04f7a38f in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#16 0x04f78137 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#17 0x04f7b12c in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#18 0x04f7b458 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#19 0x063375a0 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#20 0x0805cda2 in main (argc=1, argv=0xbf8cffc4) at main.c:602
#21 0x00dcd62f in __libc_start_main () from /lib/libc.so.6
#22 0x0804f8d1 in _start ()
Comment 1 James Laska 2005-12-06 14:00:42 EST
Hit the same issue when selecting calendar drop down when scheduling a new
appointment.

Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1208128816 (LWP 3296)]
[New Thread -1355207760 (LWP 4021)]
[New Thread -1344451664 (LWP 3608)]
[New Thread -1344185424 (LWP 3607)]
[New Thread -1343919184 (LWP 3606)]
[New Thread -1301980240 (LWP 3314)]
[New Thread -1291490384 (LWP 3313)]
[New Thread -1255384144 (LWP 3312)]
[New Thread -1244894288 (LWP 3310)]
[New Thread -1234011216 (LWP 3309)]
0x00dfa402 in __kernel_vsyscall ()
#0  0x00dfa402 in __kernel_vsyscall ()
#1  0x0056606b in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x064b938d in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  0x0805c93d in segv_redirect (sig=11) at main.c:424
#4  <signal handler called>
#5  0x0041ee59 in clearlooks_rc_style_register_type ()
   from /usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so
#6  0x0041efdf in clearlooks_rc_style_register_type ()
   from /usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so
#7  0x070496ce in gtk_paint_shadow () from /usr/lib/libgtk-x11-2.0.so.0
#8  0x06702b3f in e_calendar_item_draw (canvas_item=0x93062f8, 
    drawable=0x937af38, x=0, y=0, width=166, height=148)
    at e-calendar-item.c:917
#9  0x00d1325c in gnome_canvas_item_request_update ()
   from /usr/lib/libgnomecanvas-2.so.0
#10 0x00d18f80 in gnome_canvas_item_new () from /usr/lib/libgnomecanvas-2.so.0
#11 0x06fef170 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0x00486605 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#13 0x00486c38 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0x00496cee in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#15 0x00497e16 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#16 0x00498409 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0x070d10cf in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x00d174de in gnome_canvas_item_move () from /usr/lib/libgnomecanvas-2.so.0
#19 0x00d1758f in gnome_canvas_item_move () from /usr/lib/libgnomecanvas-2.so.0
#20 0x04f7a38f in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#21 0x04f78137 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0x04f7b12c in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#23 0x04f7b458 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#24 0x063375a0 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#25 0x0805cda2 in main (argc=3, argv=0xbfbfb464) at main.c:602
#26 0x0078f62f in __libc_start_main () from /lib/libc.so.6
#27 0x0804f8d1 in _start ()

Thread 10 (Thread -1234011216 (LWP 3309)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00562856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x002ec3b7 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#3  0x002eca86 in e_thread_busy () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#4  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 9 (Thread -1244894288 (LWP 3310)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00562856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x002ec3b7 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#3  0x002eca86 in e_thread_busy () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#4  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 8 (Thread -1255384144 (LWP 3312)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00562856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x002ec3b7 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#3  0x002eca86 in e_thread_busy () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#4  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 7 (Thread -1291490384 (LWP 3313)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00562856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x002ec3b7 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#3  0x002eca86 in e_thread_busy () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#4  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 6 (Thread -1301980240 (LWP 3314)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00562856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x002ec3b7 in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#3  0x002eca86 in e_thread_busy () from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#4  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 5 (Thread -1343919184 (LWP 3606)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0083bd50 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x04f7af82 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x04f7b458 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00a0ec0e in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x04f9339a in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 4 (Thread -1344185424 (LWP 3607)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00562856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0643898e in gnome_vfs_ssl_to_socket () from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#3  0x04f9339a in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 3 (Thread -1344451664 (LWP 3608)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00562856 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0643898e in gnome_vfs_ssl_to_socket () from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#3  0x04f9339a in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 2 (Thread -1355207760 (LWP 4021)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0083bd50 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x04f7af82 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x04f7b458 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00ba286d in e_book_set_default_source () from /usr/lib/libebook-1.2.so.5
No symbol table info available.
#5  0x04f9339a in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00560bdb in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x00845d3e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1208128816 (LWP 3296)):
#0  0x00dfa402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0056606b in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x064b938d in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x0805c93d in segv_redirect (sig=11) at main.c:424
No locals.
#4  <signal handler called>
No symbol table info available.
#5  0x0041ee59 in clearlooks_rc_style_register_type ()
   from /usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so
No symbol table info available.
#6  0x0041efdf in clearlooks_rc_style_register_type ()
   from /usr/lib/gtk-2.0/2.4.0/engines/libclearlooks.so
No symbol table info available.
#7  0x070496ce in gtk_paint_shadow () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#8  0x06702b3f in e_calendar_item_draw (canvas_item=0x93062f8, 
    drawable=0x937af38, x=0, y=0, width=166, height=148)
    at e-calendar-item.c:917
	calitem = (ECalendarItem *) 0x93062f8
	style = (GtkStyle *) 0x8849278
	bg_gc = (GdkGC *) 0x8527230
	row = 
Comment 2 James Laska 2005-12-06 14:29:36 EST
Created attachment 121943 [details]
backtrace with *many* -debuginfo rpms installed

Attaching updated backtrace with the following debuginfo packages installed:

evolution-data-server-debuginfo-1.4.2.1-1.i386
evolution-debuginfo-2.4.2-2.i386
glib2-debuginfo-2.9.0-1.i386
gnome-panel-debuginfo-2.13.2-1.i386
gtk2-debuginfo-2.8.8-1.i386
gtk2-engines-debuginfo-2.7.0-1.i386
libbonobo-debuginfo-2.13.0-1.i386
libgnomecanvas-debuginfo-2.12.0-1.i386
libgnomeui-debuginfo-2.12.0-6.i386
ORBit2-debuginfo-2.13.2-1.i386
Comment 3 Matthias Clasen 2005-12-07 11:54:08 EST
*** Bug 175057 has been marked as a duplicate of this bug. ***
Comment 4 Dave Malcolm 2005-12-09 18:27:45 EST
*** Bug 175417 has been marked as a duplicate of this bug. ***
Comment 5 Dave Malcolm 2005-12-09 18:43:21 EST
(175417 has a backtrace with better debuginfo), looks like in 
evolution/widgets/misc/e-calendar-item.c:
e_calendar_item_draw()
calls gtk_paint_shadow with NULL area and NULL widget (which the API docs say
are valid to be NULL), detail is "entry".

Possible dup of the bug fixed by this commit?
    * engines/clearlooks/src/clearlooks_draw.c:
    (clearlooks_draw_progressbar_trough):
    * engines/clearlooks/src/clearlooks_style.c:
    (clearlooks_set_widget_parameters):

    Fixed crash in gnumeric. The bug was potentially harmful
    to other apps as well.
So maybe we just a newer upstream tarball release?
Comment 6 Matthias Clasen 2005-12-11 01:07:47 EST
I added that fix to gtk2-engines-2.7.0-2. Let me know if that doesn't fix it.
Comment 7 Dave Malcolm 2005-12-13 00:05:27 EST
(gtk2-engines-2.7.0-2 seems to fix it)

Note You need to log in before you can comment on or make changes to this bug.