This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 175106 - lsof -b still blocks on gethostbyname causing slow force unmount; use -bn instead
lsof -b still blocks on gethostbyname causing slow force unmount; use -bn ins...
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
: 175906 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-06 12:48 EST by Lon Hohberger
Modified: 2009-04-16 16:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0173
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 15:24:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2005-12-06 12:48:10 EST
+++ This bug was initially created as a clone of Bug #171637 +++

Description of problem:

If clumanager has a service configured with force unmount support and that
service is stopped, the stop phase can take a VERY long time to complete if lsof
is used and DNS is cut off.

The solution is to add "-n" to the lsof option string so that DNS is not used.

-- Additional comment from lhh@redhat.com on 2005-11-10 16:55 EST --
Created an attachment (id=120910)
Fixes behavior


-- Additional comment from lhh@redhat.com on 2005-11-10 17:04 EST --
Setting to modified.

-- Additional comment from lhh@redhat.com on 2005-11-11 15:58 EST --
A new *TEST* package build with several bugfixes (fixes bugzillas: 171637 172735
172893 172894 ) is available.  Gulm-bridge support has been disabled in this
release to prevent having to install with the "--nodeps" option:

http://people.redhat.com/lhh/clumanager-1.2.28.6-0.1nogfs.i386.rpm
http://people.redhat.com/lhh/clumanager-1.2.28.6-0.1nogfs.x86_64.rpm
http://people.redhat.com/lhh/clumanager-1.2.28.6-0.1nogfs.src.rpm

Let us know if this works for you.
Comment 1 Lon Hohberger 2005-12-06 12:49:23 EST
Just a clone for RHCS4.  I have a fix ready; it'll go in with the rest today.
Comment 2 Lon Hohberger 2005-12-06 13:49:16 EST
Fixes in CVS ready for QA.

Branches: head, STABLE, RHEL4
Comment 3 Ngo Than 2005-12-16 09:34:10 EST
*** Bug 175906 has been marked as a duplicate of this bug. ***
Comment 4 Red Hat Bugzilla 2006-01-06 15:24:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0173.html

Note You need to log in before you can comment on or make changes to this bug.