This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 17520 - Corruption of active-file
Corruption of active-file
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: inn (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-14 18:58 EDT by Enrico Scholz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-14 18:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2000-09-14 18:58:52 EDT
When running inn a while, the active-file the active file becomes corrupted
(high-marks are set to a lower value than they should be):

| # getlist >/tmp/innd.1
| # ctlinnd renumber ""
| Ok
| # getlist >/tmp/innd.2
| # diff -u /tmp/innd.{1,2}
| -chemnitz.comp 0000003954 0000002845 y
| -chemnitz.markt 0000006443 0000004937 y
| -chemnitz.tu.allgemein 0000007820 0000002212 y
| -chemnitz.tu.informatik 0000000916 0000000437 y
| -chemnitz.tu.urz 0000001839 0000001310 y
| +chemnitz.comp 0000003957 0000002845 y
| +chemnitz.markt 0000006450 0000004937 y
| +chemnitz.tu.allgemein 0000007821 0000002212 y
| +chemnitz.tu.informatik 0000000917 0000000437 y
| +chemnitz.tu.urz 0000001841 0000001310 y

(I haven't fetched any article between both getlist's (yes, I'm sure...)).
Only groups I have read articles from seem to be affected (but not every
one). I don't know how to trigger this error (inn ran around 12h before
this test and active was ok at starttime), perhaps it happens when client
was disconnected because of a timeout.

Currently active news-related processes are:
| # ps axf
| 16959 pts/1    S      0:03 /usr/bin/actived
| 16960 ?        S      0:11 /usr/bin/innd -p4 -r -L
| 16963 ?        S      0:00  \_ /usr/bin/crosspost
| 16964 ?        SW     0:00  \_ /usr/bin/archive -f -i
/var/spool/news/archive/INDEX
| 16965 ?        S      0:00  \_ /usr/bin/overchan
| 19897 ?        S      0:08  \_ -kosh.ultra.csn.tu-chemnitz.de LIST


I don't know where I have to look for the error because it happens only
after a certain time/some activities.
Comment 1 Enrico Scholz 2000-11-21 16:37:21 EST
Have not seen it anymore since update to linux-2.4.0-test9. Perhaps a nmap-bug
in previous kernel-versions...

Note You need to log in before you can comment on or make changes to this bug.