Bug 17521 - kickstart floppy net-install uses wrong drive geometry on ProLiant ML330
kickstart floppy net-install uses wrong drive geometry on ProLiant ML330
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-14 20:14 EDT by John Cagle
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-06 13:23:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file (816 bytes, text/plain)
2000-09-14 20:19 EDT, John Cagle
no flags Details

  None (edit)
Description John Cagle 2000-09-14 20:14:17 EDT
Machine: ProLiant ML330
Storage: 9.1GB SCSI drive using an NCR 53c895a controller.
LILO: installed to /boot partition, not MBR.

When performing a network-kickstart install (see attached ks.cfg), LILO thinks the drive
geometry is [8678 Cylinders, 64 Heads, 32 Sectors], but the BIOS reports via
INT13 a geometry of [1106 Cylinders, 255 Heads, 63 Sectors].  This causes
LILO to place the boot loader at the wrong physical location on the disk.  This leads to
a "Missing Operating System" error at boot time.

Doing a custom install from the CD-ROM uses the correct geometry and everything
works fine.
Comment 1 John Cagle 2000-09-14 20:19:40 EDT
Created attachment 3426 [details]
kickstart file
Comment 2 Michael Fulbright 2000-09-29 12:39:05 EDT
Brock can you reproduce?
Comment 3 Brock Organ 2000-11-06 13:23:40 EST
There are two bug assertions above:

1) LILO writes it's partition information to the wrong location on disk
2) because of 1), the system is not bootable

In testing the LILO partition information is located in it's proper place on
disk (first 512 bytes of sda1) ... this shows LILO is not writing data to the
wrong location (ie 1) is not a bug...)

Secondly, without proper boot redirection from the MBR, the system not being
bootable is not a bug; placing LILO on the first sector of boot/root partition
implicitly requires help from the MBR ... (ie 2) is not a bug ...)

Below are listed the octal character dump (od -c) of the first few bytes from
sda and sda1 post-install (note: the drive sda was zeroed entirely before this
test was run!)

Here is the MBR from sda (post-LILO): (od -c dump of first 1k)

0000000  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0         
*
0000660  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0 200 001
0000700 001  \0 203   ?     020      \0  \0  \0 340 207  \0  \0  \0  \0
0000720 001 021 005   ? 340 377  \0 210  \0  \0  \0 250 016 001  \0  \0
0000740  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
0000760  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0   U 252
0001000

Note the first 512 bytes are empty ... zeroed out ... LILO did not affect this
area ... 

Here are the first few bytes of sda1:

0000000 372 353   |   l   b   a   L   I   L   O 001  \0 025 004   Z  \0
0000020  \0  \0  \0  \0 027 247 006   : 363   H 300  \0 001 364   H 300
0000040  \0 001 362   H 300  \0 001 001   D   Z 366   H 300  \0 001 367
0000060   H 300  \0 001 351   < 300  \0 001 352   < 300  \0 001 353   <
0000100 300  \0 001 354   < 300  \0 001 355   < 300  \0 001 356   < 300
0000120  \0 001 357   < 300  \0 001 360   < 300  \0 001 361   < 300  \0
0000140 001 362   < 300  \0 001 363   < 300  \0 001  \0  \0  \0  \0  \0
0000160  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0 270   

The LILO string appears in it's proper place, showing that LILO indeed wrote the
proper information to the proper location (ie boot sector of sda1) instead of a
bad location on disk ... 

I hope this helps, please reopen if there are other issues not being addressed
... thanks for your
report!

Note You need to log in before you can comment on or make changes to this bug.