Bug 175226 - libtool tries linking 64 bit build with 32 bit popt
libtool tries linking 64 bit build with 32 bit popt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ORBit2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 16:31 EST by David Juran
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 13:33:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2005-12-07 16:31:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The libtool that comes with ORBit2 is broken in respect to multilib. When building ORBit2.x86_64, if you hapen to have popt-1.10.1-22.i386 installed, you'll get the following error:

/bin/sh ../../libtool --mode=link gcc  -Werror-implicit-function-declaration -std=gnu89 -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m64 -mtune=nocona   -o orbit-idl-2  orbit-idl-main.o orbit-idl-driver.o orbit-idl-backend.o orbit-idl-utils.o orbit-idl-c-backend.o orbit-idl-c-stubs.o orbit-idl-c-skels.o orbit-idl-c-headers.o orbit-idl-c-common.o orbit-idl-c-imodule.o orbit-idl-c-skelimpl.o orbit-idl-c-utils.o orbit-idl-c-typecode.o orbit-idl-c-deps.o -Wl,--export-dynamic -lIDL-2 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   -lpopt -lm
mkdir .libs
gcc -Werror-implicit-function-declaration -std=gnu89 -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m64 -mtune=nocona -o orbit-idl-2 orbit-idl-main.o orbit-idl-driver.o orbit-idl-backend.o orbit-idl-utils.o orbit-idl-c-backend.o orbit-idl-c-stubs.o orbit-idl-c-skels.o orbit-idl-c-headers.o orbit-idl-c-common.o orbit-idl-c-imodule.o orbit-idl-c-skelimpl.o orbit-idl-c-utils.o orbit-idl-c-typecode.o orbit-idl-c-deps.o -Wl,--export-dynamic  -lIDL-2 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 /usr/lib/libpopt.so -lm
/usr/lib/libpopt.so: could not read symbols: File in wrong format



Since the current FC libtool is working fine, the remedy is to add the line:

libtoolize --force --copy && aclocal && autoconf

to the %build section of the specfile, right before %configure

Version-Release number of selected component (if applicable):
ORBit2-2.13.2-1

How reproducible:
Always

Steps to Reproduce:
1. install popt.i386
2. build ORBit2.x86_64
3.
  

Additional info:

Note You need to log in before you can comment on or make changes to this bug.