Bug 175251 - libGLw: Missing motif support
libGLw: Missing motif support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: 173883
  Show dependency treegraph
 
Reported: 2005-12-07 21:47 EST by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-24 03:34:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Activate Xm for libGLw in mesa's config. (760 bytes, patch)
2005-12-07 21:50 EST, Ralf Corsepius
no flags Details | Diff

  None (edit)
Description Ralf Corsepius 2005-12-07 21:47:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
Motif support is missing in libGLw.


Version-Release number of selected component (if applicable):
mesa-libGLw-6.4-5

How reproducible:
Always

Steps to Reproduce:
1. nm -sDg /usr/lib/libGLw.so.1.0.0

  

Actual Results:  Check the output of the "nm" call above for Motif symbols.

All GLwMDrawingArea support is missing.


Expected Results:  Almost all packages using libGLw are motif based and expect the GLwMDrawingArea class as part of libGLw.


Additional info:
Comment 1 Ralf Corsepius 2005-12-07 21:50:22 EST
Created attachment 122021 [details]
Activate Xm for libGLw in mesa's config.

From what I see in the sources, this patch should activate building motif
support for libGLw.

Due to other packaging bugs in mesa, which prevent building mesa in an FC5
chroot, this patch is untested.
Comment 2 Mike A. Harris 2005-12-24 03:34:34 EST
Fixed in 6.4.1-3

Note You need to log in before you can comment on or make changes to this bug.