Bug 175305 - rpm 'C' failure flag not documented in man page
rpm 'C' failure flag not documented in man page
Status: CLOSED DUPLICATE of bug 175304
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-12-08 12:59 EST by David Tonhofer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-08 14:11:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2005-12-08 12:59:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
I wanted to check the kernel RPM using rpm --verify:

[root@greyhound ~]# rpm --verify kernel
........C   /boot/System.map-2.6.9-11.EL
........C   /boot/config-2.6.9-11.EL
........C   /boot/vmlinuz-2.6.9-11.EL
........C   /boot/System.map-2.6.9-22.EL
........C   /boot/config-2.6.9-22.EL
........C   /boot/vmlinuz-2.6.9-22.EL
........C   /boot/System.map-2.6.9-22.0.1.EL
........C   /boot/config-2.6.9-22.0.1.EL
........C   /boot/vmlinuz-2.6.9-22.0.1.EL

The question is: what does the 'C' mean?

This flag is not explained in the rpm manpage. I imagine it has not been
completed yet? There it says:

<<< quote <<<

The format of the output is a string of 8 characters, a possible attribute marker:

c %config configuration file.
d %doc documentation file.
g %ghost file (i.e. the file contents are not included in the package payload).
l %license license file.
r %readme readme file.

from the package header, followed by the file name.  Each of the 8 characters
denotes the result of a comparison of attribute(s) of the file to the
value of those attribute(s) recorded in the database.  A single "." (period)
means the test passed, while a single "?" (question mark) indicates the
test  could not be performed (e.g. file permissions prevent reading). Otherwise,
the (mnemonically emBoldened) character denotes failure of the corresponding
--verify test:

       S file Size differs
       M Mode differs (includes permissions and file type)
       5 MD5 sum differs
       D Device major/minor number mismatch
       L readLink(2) path mismatch
       U User ownership differs
       G Group ownership differs
       T mTime differs

>>> quote >>>

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
not really applicable...
see above

Actual Results:  see above

Expected Results:  see above

Additional info:

see above
Comment 1 David Tonhofer 2005-12-08 14:11:38 EST

*** This bug has been marked as a duplicate of 175304 ***

Note You need to log in before you can comment on or make changes to this bug.