Bug 175353 - Package update synchronization: Repositories claim that updates are available before packages are physically present on servers
Package update synchronization: Repositories claim that updates are available...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-09 05:04 EST by Stephen Biggs
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 09:41:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Biggs 2005-12-09 05:04:10 EST
Description of problem:
I tried to search for any duplicates of this bug/problem in the bugzilla
database but came up short since I also don't quite know what to search for. If
this is, in fact, a duplicate, my apologies for the noise.  Also, this is a
all-packages repository-wide problem but the bug entry page here forces me to
enter a component, so I guessed.

When attempting to run APT-GET on the extras packages, the servers show that
updates are present and these updates are taken into account in the download
computations.  Attempts to download the packages fail because they are not
physically present on the server(s).

I am using ayo.*.freshrpms.net extras repositories, doesn't matter which mirror.
 This also happens with the main repository. Perhaps this is a freshrpms server
problem?

Version-Release number of selected component (if applicable):


How reproducible:
Need to jump in and see the updates reported before the packages are on the
server.  Difficult to say how to reproduce this.

Steps to Reproduce:
1. See above.
2.
3.
  
Actual results:
Error output from Synaptic for RPM:
W: Failed to fetch
http://ayo.freshrpms.net/fedora/linux/4/i386/RPMS.extras/OpenSceneGraph-devel-0.9.9-4.fc4.1.i386.rpm
  404 Not Found


Expected results:
All files that are reported as available should be present for download. 
What should happen is that updates should not be marked as present until the
physical packages are also present first.  This prevents constant
checking/polling for updates that are already reported as needed but no packages
available due to mirror updating.

Additional info:
Comment 1 Ville Skyttä 2006-03-28 09:58:53 EST
I wonder why this was assigned to me?  Reassigning to Matthias who is more
likely to be able to say something about freshrpms.net mirrors...
Comment 2 Matthias Saou 2006-03-28 10:13:10 EST
Well, this problem is know, and I don't have any magic solution for it. The
problem is that the apt metadata is generated on a private mirror server, then
sent to the main ayo.freshrpms.net server, which is ftp.heanet.ie currently. But
that public server seems to sync Fedora updates less often than the private
server, so apt ends up telling you that updates are available, although they
aren't yet in reality.

The best long term solution to this problem is to have apt use repomd metadata
and rely on the main Fedora generated metadata instead of on the one generated
"off site", since it'll always be in sync with the packages actually present on
the server.
Comment 3 Matthias Saou 2006-04-07 09:41:02 EDT
I'm going to resolve this bug as DEFERRED, as :
- It is not directly related to Fedora packages or Fedora infrastructures
- The proper fix will be to have an apt package that supports repomd, which
  will luckily happen some day, since Panu has been working on it.

Note You need to log in before you can comment on or make changes to this bug.