Bug 175373 - Request to update libmultipath/hwtable.c entry for EMC CLARiiON.
Summary: Request to update libmultipath/hwtable.c entry for EMC CLARiiON.
Status: CLOSED DUPLICATE of bug 174441
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath   
(Show other bugs)
Version: 4.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ben Marzinski
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-09 16:28 UTC by Ed Goggin
Modified: 2010-01-12 02:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-06 16:30:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Goggin 2005-12-09 16:28:53 UTC
Description of problem:
Description of problem:

I have made two submissions for updating parameters for the store_hwe_ext macro 
call for the EMC CLARiiON in the last few months to the upstream multipath-
tools git head for libmultipath/hwtable.c.  The first submission establishes
immediate failback as the path group failback policy for the CLARiiON.  The 
second submission changes the product parameter string of the macro call to
"^[^LUN_Z]" from "*" in order to force multipath to recognize all CLARiiON 
logical units but the one which responds to a SCSI inquiry with the model 
string "LUN_Z           ".

This bugzilla is here just to make sure that the changes introduced by these 
submissions are included in the Update 3 release of RH 4.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ed Goggin 2005-12-15 19:21:25 UTC
My patch submitted upstream to the hwentry for CLARiiON for
multipath-tools/libmultipath/hwtable.c should have used a model string of
"^[^LUNZ]" instead of "^[^LUN_Z]".  NO UNDERSCORE!

Can you please integrate this change into the multipath-tools package for 
Update 3 of RHEL4?

Comment 2 Ed Goggin 2005-12-16 15:34:34 UTC
More work is required to provide this functionality than I had previously 
thought necessary.  Because of this, the vendor field of the store_hwe_ext() 
macro for the EMC CLARiiON should be left at "*", that is, no further change is 
necessary for Update 3.

Comment 3 Ben Marzinski 2005-12-20 18:02:22 UTC
I'm going leave this bug open as a placeholder for the generic clariion problem.

Comment 4 Alasdair Kergon 2006-03-08 16:53:13 UTC
Need clarification of exactly what we should change, if anything, for U4.

Comment 5 Alasdair Kergon 2006-04-06 16:30:53 UTC

*** This bug has been marked as a duplicate of 174441 ***


Note You need to log in before you can comment on or make changes to this bug.