This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 175377 - Negative "Memory" for big processes
Negative "Memory" for big processes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-system-monitor (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
: Desktop
Depends On:
Blocks: 187539
  Show dependency treegraph
 
Reported: 2005-12-09 11:44 EST by Bastien Nocera
Modified: 2014-06-18 05:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0325
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 17:08:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-system-monitor-dont-truncate-sizes-rhel3.patch (2.12 KB, patch)
2005-12-14 13:22 EST, Bastien Nocera
no flags Details | Diff
gnome-system-monitor-dont-truncate-sizes-rhel3-2.patch (2.77 KB, patch)
2005-12-15 04:50 EST, Bastien Nocera
no flags Details | Diff
gnome-system-monitor-sorting.patch (424 bytes, patch)
2005-12-15 11:00 EST, Bastien Nocera
no flags Details | Diff
gnome-system-monitor-sorting2.patch (465 bytes, patch)
2005-12-19 05:32 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2005-12-09 11:44:41 EST
gnome-system-monitor shows "-1211551744 bytes" for the memory, whereas top shows
"10.9 GB".

libgtop2-2.0.2-3-x86_64
gnome-system-monitor-2.0.5-4-x86_64

Similar to bug #175375 on RHEL4.
Comment 1 Bastien Nocera 2005-12-14 13:22:59 EST
Created attachment 122236 [details]
gnome-system-monitor-dont-truncate-sizes-rhel3.patch
Comment 2 Bastien Nocera 2005-12-14 13:23:34 EST
Test packages at:
http://people.redhat.com/bnocera/g-s-m/rhel3/
Comment 3 Bastien Nocera 2005-12-14 14:16:24 EST
The packages won't work, struct _ProcInfo in src/procman.h stores the memory
details in an int, instead of a gint64.
Comment 4 Bastien Nocera 2005-12-15 04:50:46 EST
Created attachment 122269 [details]
gnome-system-monitor-dont-truncate-sizes-rhel3-2.patch
Comment 5 Bastien Nocera 2005-12-15 04:51:31 EST
Test packages at:
http://people.redhat.com/bnocera/g-s-m/rhel3/
Comment 6 Bastien Nocera 2005-12-15 08:01:03 EST
Tested successfully.
Comment 8 Bastien Nocera 2005-12-15 11:00:30 EST
Created attachment 122287 [details]
gnome-system-monitor-sorting.patch

Another patch on top to unbreak the sorting.
Comment 10 Bastien Nocera 2005-12-19 05:32:03 EST
Created attachment 122393 [details]
gnome-system-monitor-sorting2.patch

And the 2nd patch in the right direction.
Comment 12 Steffen Mann 2006-01-30 10:54:04 EST
As the hofix for U7 was denied could you please ensure that this will make it
into U8 then.
Comment 13 Mike A. Harris 2006-03-28 09:41:38 EST
Bug shouldn't be in MODIFIED state, or it'll miss U8.
Comment 15 Søren Sandmann Pedersen 2006-04-11 16:59:54 EDT
Devel ack. This bug was fixed and a new package (2.7.0-5) was built on Jan 9.

Comment 16 Søren Sandmann Pedersen 2006-04-11 17:01:45 EDT
I meant 2.0.5-5.
Comment 17 Søren Sandmann Pedersen 2006-04-11 17:02:30 EDT
Since this package is already built, it could be fasttracked.
Comment 23 Red Hat Bugzilla 2006-05-03 16:16:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0325.html
Comment 24 Red Hat Bugzilla 2006-05-03 17:08:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0325.html

Note You need to log in before you can comment on or make changes to this bug.