Bug 175443 - text install fails
text install fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-10 13:34 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-10 20:17:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-12-10 13:34:32 EST
File "/usr/lib/anaconda/textw/simple_pkgselect_text.py", line 40, in __call__
groups = backend.ayum.groupInfo.visible_groups AttributeError: AnacondaYum
instance has no attribute 'groupInfo'
Comment 1 Jeremy Katz 2005-12-10 20:17:53 EST
Simple port to the new groups stuff committed to CVS
Comment 2 David Woodhouse 2005-12-11 04:25:06 EST
I copied these files from anaconda CVS into $installtree/RHupdates:

backend.py   GroupSelector.glade       yuminstall.py
dispatch.py  simple_pkgselect_text.py

Now I see this error instead... did I miss something else I should have updated?

             │     rc = apply(func, self.bindArgs(args))       ▒ │ 
             │   File "/mnt/source/RHupdates/backend.py",      ▒ │ 
             │ line 140, in doRepoSetup                        ▒ │ 
             │     backend.doRepoSetup(intf, instPath)         ▒ │ 
             │   File "/mnt/source/RHupdates/yuminstall.py",   ▒ │ 
             │ line 549, in doRepoSetup                        ▒ │ 
             │     self._catchallCategory()                    ▒ │ 
             │   File "/mnt/source/RHupdates/yuminstall.py",   ▒ │ 
             │ line 557, in _catchallCategory                  ▒ │ 
             │     if g.user_visible:                            │  
             │ AttributeError: 'str' object has no attribute   ▒ │  
             │ 'user_visible'                                  ▒ │ 
Comment 3 David Woodhouse 2005-12-11 07:00:55 EST
Now that today's rawhide tree is finally built, it does start up OK. 
Running with the 'debug' option I get this traceback shortly after it starts
installing packages though...


        ┌─────│ line 428, in _run                           ▒ │ ─────┐ 
         │     │     self.runTransaction(cb=cb)              ▒ │      │ 
         │  Nam│   File                                      ▒ │      │ 
         │  Siz│ "/usr/lib/python2.4/site-packages/yum/__in  ▒ │      │ 
         │  Sum│ it__.py", line 369, in runTransaction       ▒ │      │ 
         │     │     errors = self.ts.run(cb.callback, '')   ▒ │      │ 
         │     │   File "/usr/lib/anaconda/yuminstall.py",   ▒ │      │ 
         │     │ line 120, in callback                       ▒ │      │ 
         │     │     self.instLog.flush()                    ▒ │      │ 
         │     │ IOError: [Errno 30] Read-only file system   ▒ │ 
Comment 4 David Woodhouse 2005-12-11 07:10:12 EST
Same traceback happens without 'debug' too.
Comment 5 David Woodhouse 2005-12-11 10:25:21 EST
and also in vnc mode, although helpfully the text box showing the traceback is
completely black (http://david.woodhou.se/vnc5.jpeg) 

anaconda.log contains this...

  File "/usr/lib/anaconda/gui.py", line 1215, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 245, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 923, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/backend.py", line 152, in doInstall
    backend.doInstall(intf, id, instPath)
  File "/usr/lib/anaconda/yuminstall.py", line 825, in doInstall
    self.ayum.run(self.instLog, cb, intf)
  File "/usr/lib/anaconda/yuminstall.py", line 412, in run
    self._run(instLog, cb, intf)
  File "/usr/lib/anaconda/yuminstall.py", line 428, in _run
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 369, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/anaconda/yuminstall.py", line 120, in callback
    self.instLog.flush()
IOError: [Errno 30] Read-only file system


Comment 6 David Woodhouse 2005-12-11 10:40:45 EST
/mnt/sysimage got remounted read-only due to an error....

EXT3-fs error (device dm-0): ext3_add_entry: bad entry in directory #917787:
rec_len is smaller than minimal - offset=0, inode=0, rec_len=0, name_len=0
Aborting journal on device dm-0.
EXT3-fs error (device dm-0) in ext3_reserve_inode_write: Journal has aborted
ext3_abort called.
EXT3-fs error (device dm-0): ext3_journal_start_sb: Detected aborted journal
Remounting filesystem read-only
EXT3-fs error (device dm-0) in start_transaction: Journal has aborted

This is happening even when the kernel is rebuilt with gcc 4.0. I suspected mkfs
but that only created an empty file system.

dhowells did upgrade the kernel (and vscsi server) on the service partition of
this machine a few days ago.... I wonder if that's the problem.

Note You need to log in before you can comment on or make changes to this bug.