Bug 175481 - Compatibility problem with action function in functions script
Compatibility problem with action function in functions script
Status: CLOSED DUPLICATE of bug 161316
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 12:24 EST by Evert Verhellen
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-12 14:04:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evert Verhellen 2005-12-11 12:24:22 EST
Description:

The action function in the functions script of the initscripts package doesn't
work as before. The following piece of code ran fine with Fedora Core 3
(initscripts 7.93.2):

    . /etc/rc.d/init.d/functions

    ORACLE_OWNER="oracle"

    action $"Starting Oracle Enterprise Manager 10g Database Control:" \
        "su - ${ORACLE_OWNER} -c '\${ORACLE_HOME}/bin/emctl start dbconsole'"

Results with Fedora Core 4 (initscripts 8.11.1):

Stopping Oracle Enterprise Manager 10g Database Control: stop: -c: line 0:
unexpected EOF while looking for matching `''
stop: -c: line 1: syntax error: unexpected end of file
                                                           [FAILED]

Which is strange because nothing is wrong with the quoting itself. Changing the
quoting as follows supresses the above error message:

    action $"Starting Oracle Enterprise Manager 10g Database Control:" \
        su - ${ORACLE_OWNER} -c "\${ORACLE_HOME}/bin/emctl start dbconsole"

However ... When doing this the arguments `start' and `dbconsole' are apparently
just dropped. Which is again a problem because `emctl' just displays the usage.
Comment 1 Bill Nottingham 2005-12-12 14:04:35 EST

*** This bug has been marked as a duplicate of 161316 ***

Note You need to log in before you can comment on or make changes to this bug.