Bug 175483 - System settings missing from menu/can't edit Kmenu
System settings missing from menu/can't edit Kmenu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 13:39 EST by Kim Lux
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 10:43:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2005-12-11 13:39:54 EST
Description of problem: 
 
System settings missing from menu/can't edit Kmenu 
 
See http://bugs.kde.org/show_bug.cgi?id=118079 
 
KDE says it is a Redhat problem.  
 
 
Version-Release number of selected component (if applicable): 
 
rpm -q kdebase 
kdebase-3.5.0-1.1.fc4.kde 
 
Steps to Reproduce: 
1. Update to KDE3.5 
   
Actual results: 
 
Menus are different on every user.  Mine is missing System Settings.  
 
Expected results: 
 
System Settings should be there.  
 
Additional info:
Comment 1 Kim Lux 2005-12-12 17:18:07 EST
I upgraded a second machine to kde 3.5. The same sort of thing happened.   
 
It looks to me like the session that runs the update doesn't get System 
Settings in the menu. 
 
For example, on the first machine I ran su synaptic from my personal account 
and now I don't have System Settings in my personal menu.  The other users do 
have System Settings.   
 
On the next machine I ran su synaptic from a user account and again no System 
Settings in that users account.  
 
Comment 2 Lieven 2005-12-24 06:09:10 EST
Same problem here. I try to find out where exactly the kmenu settings are stored
but up to now, no result. When I create a new user and start kde with this user
logged in, the kmenu is complete again. I have copied the /root/.kde/ contents
to a safe place and then I deleted the original contents of /root/.kde . After
restarting kde, the kmenu was still incomplete. So I think that the default
settings are coming from somwhere else and eventually depending on the type of
user (root or normal user)
Comment 3 Keith Freiheit 2005-12-29 01:41:50 EST
I had the same problem under fc3. I updated to kde 3.5 and suddenly my kmenu was
missing several items. I eventually renamed my local .kde directory and
rebooted. That fixed the menu, but of course I lost all of my kde settings. I
then renamed the new .kde directory and restored the original and rebooted. That
gave me the corrected menu and my kde settings. Seems like something just needed
a good kick to get things working correctly.

Comment 4 Kim Lux 2006-10-30 10:13:42 EST
This was recently a problem again on my FC4 to fc6 upgrade.

I solved it with the following 

1) log in, runnging kde
2) $ mv ~/.config/menus `~/.config/menus.BAK 
3) $ kbuildsycoca

Someone has mentioned the problem occurs only for people that have edited 
their menus.  I can't confirm that, but I have edited my menus. 
Comment 5 Ngo Than 2006-10-30 10:43:43 EST
it'a known issue and has been fixed in KDE-3.5.5. It's already available for 
FC5/FC-update. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.