Bug 175505 - chroot creation not possible on rawhide
chroot creation not possible on rawhide
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 19:57 EST by Rudolf Kastl
Modified: 2014-01-21 17:53 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 03:12:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2005-12-11 19:57:30 EST
Description of problem:
mach -r f4l64 setup build
Installing package set 'minimal' ...!
error: /usr/sbin/mach-helper yum -c
/var/lib/mach/states/fedora-4-x86_64-livna/yum.conf
--installroot=/var/lib/mach/roots/fedora-4-x86_64-livna  -y -y install bash
glibc failed.
 Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 257, in getOptionsConfig
    self.conf.installroot = opts.installroot
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 58, in __set__
    optdata = getattr(obj, self._attrname)
AttributeError: 'YumConf' object has no attribute '__opt2AAAAC6539D0'

Retrying installing package set 'minimal' ...!
error: /usr/sbin/mach-helper yum -c
/var/lib/mach/states/fedora-4-x86_64-livna/yum.conf
--installroot=/var/lib/mach/roots/fedora-4-x86_64-livna  -y -y install bash
glibc failed.
 Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 257, in getOptionsConfig
    self.conf.installroot = opts.installroot
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 58, in __set__
    optdata = getattr(obj, self._attrname)
AttributeError: 'YumConf' object has no attribute '__opt2AAAAC6539D0'

ERROR: Could not yum -y install bash glibc

Version-Release number of selected component (if applicable):
mach-0.4.8-1.fc5, yum-2.5.0-0.20051210
Comment 1 Thomas Vander Stichele 2005-12-18 05:07:14 EST
this looks like a yum bug, not a mach bug.

this execution is failing:

yum -c
/var/lib/mach/states/fedora-4-x86_64-livna/yum.conf
--installroot=/var/lib/mach/roots/fedora-4-x86_64-livna  -y -y install bash
glibc

Try this as root, it will fail in the same way.

can you file a bug against yum in core instead ?
Comment 2 Patrick Barnes 2005-12-19 20:03:26 EST
Re-assigning accordingly.
Comment 3 Seth Vidal 2005-12-20 03:12:52 EST
I think I found the bug and it's been fixed in yum cvs.

thanks

oh and when you reassign a bug - make sure you tell bugzilla to:

  Reassign bug to owner and QA contact of selected component 

so it adds the right addresses to it.

thanks
Comment 4 Seth Vidal 2005-12-20 03:14:05 EST
I assigned it wrongly.

Note You need to log in before you can comment on or make changes to this bug.