This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 175562 - yum CVS does not list packages in development repo
yum CVS does not list packages in development repo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-12 15:04 EST by Ian Burrell
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 13:05:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Burrell 2005-12-12 15:04:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051129 Fedora/1.5-1 Firefox/1.5

Description of problem:
The yum CVS in rawhide is not showing packages in the development repository.  The cause seems to be that it is using the extras-development metadata to build the development cache.  This hides all the true development packages and reports extras-development packages as development.

Version-Release number of selected component (if applicable):
yum-2.5.0-0.20051210

How reproducible:
Always

Steps to Reproduce:
1. yum clean metadata
2. yum list kde\*
  

Actual Results:  Loading "installonlyn" plugin
Setting up repositories
extras-development        100% |=========================| 1.1 kB    00:00
development               100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 936 kB    00:25
extras-dev: ################################################## 2607/2607
Added 0 new packages, deleted 1 old in 2.32 seconds
primary.xml.gz            100% |=========================| 936 kB    00:08
developmen: ################################################## 2607/2607
Added 0 new packages, deleted 1 old in 2.51 seconds
Available Packages
kdesvn.x86_64                            0.7.0-0.rc1.fc5        development

Notice that none of the kde packages in core showed up.  kdesvn is actually in extras.  Also, the count of packages for development is the same as extras (2607).  development should have more like 4635 packages.  The /var/cache/yum/development files are the same as /var/cache/yum/extras-development files.  The /var/cache/yum/development/repomd.xml seems to be the extras one.  

The /etc/yum.repos.d/fedora-devel.repo and fedora-extras-devel.repo are unchanged.  I checked all the mirrors and they have the correct repomd.xml.

Expected Results:  Doing this works:

yum --disablerepo=* --enablerepo=development list kde\*

Loading "installonlyn" plugin
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.3 MB    00:06
developmen: ################################################## 4635/4635
Added 4635 new packages, deleted 2608 old in 20.59 seconds
Available Packages
kde-i18n-Arabic.noarch                   1:3.5.0-1.1            development
kde-i18n-Bengali.noarch                  1:3.5.0-1.1            development


Additional info:

This happens with yum-2.5.0-0.20051210 and yum-2.5.0-0.20051207.
Comment 1 Ian Burrell 2005-12-18 17:31:46 EST
This problem has gone away with yum-2.5.0-4.

Note You need to log in before you can comment on or make changes to this bug.