Bug 175567 - Feature requests: more notification
Feature requests: more notification
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
http://www.ax-tech.net
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-12 16:32 EST by Andrei Thorp
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.99.5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 03:02:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Thorp 2005-12-12 16:32:47 EST
Description of problem:

Great product, but it could use some small touch ups to make it seem really
professional. For one thing, it would be cool if you used the notification area
for updates and stuff so that I don't have to use up two slots of my window bar.
It would be further cool if the little icon then popped up and told me when
things were done or if errors occured or whatever.

Second, I think it would be nice if the program told me how far I was into
installing/updating/removing whatever. If I'm updating 60 apps, I would like to
at least know how far into it I am. Also, if you've ever updated an iPod with
iTunes, then you may have noticed that it checks off which ones still need work
and which ones are updated, so again, you know how far in you are.

Third, it would be great if when you resize things on the interface, it would
apply that to all the various windows that are accessed by the side tabs, like
if I changed the height of the bottom segment, that would change for all the
various screens of the program, or if I changed the width of the info fields on
the update screen (description, name, repo, etc) it would be nice if they also
changed to the same amount on the install window.

Aside form that, great program, and 10x better than what RedHat gives us to
update our gear. Synaptic always made me jealous, so this is a real relief.
Great work, and thanks. I'm kind of nitpicking I know, but this thing is near
perfect and I'd like to see it get to utter perfection.
Comment 1 Rahul Sundaram 2005-12-12 17:21:46 EST

Just a note that libnotify will land up in the development tree soonish so you
might want to use that for providing notifications. 
Comment 2 Tim Lauridsen 2005-12-15 04:25:05 EST
(In reply to comment #0)
> Description of problem:
> 
> Great product, but it could use some small touch ups to make it seem really
> professional. For one thing, it would be cool if you used the notification area
> for updates and stuff so that I don't have to use up two slots of my window bar.
check out the latest devel edition og yumex http://linux.rasmil.dk/dnl/yumex-devel
I have made some changes to the dialogs, progress dialog has been integrated in
the main gui window.
> It would be further cool if the little icon then popped up and told me when
> things were done or if errors occured or whatever.
> 
Nice idea, i will try to figure something out

> Second, I think it would be nice if the program told me how far I was into
> installing/updating/removing whatever. If I'm updating 60 apps, I would like to
> at least know how far into it I am. Also, if you've ever updated an iPod with
> iTunes, then you may have noticed that it checks off which ones still need work
> and which ones are updated, so again, you know how far in you are.
> 
I will put it my todo list.

> Third, it would be great if when you resize things on the interface, it would
> apply that to all the various windows that are accessed by the side tabs, like
> if I changed the height of the bottom segment, that would change for all the
> various screens of the program, or if I changed the width of the info fields on
> the update screen (description, name, repo, etc) it would be nice if they also
> changed to the same amount on the install window.
> 
I will put this on my todo list too.
> Aside form that, great program, and 10x better than what RedHat gives us to
> update our gear. Synaptic always made me jealous, so this is a real relief.
> Great work, and thanks. I'm kind of nitpicking I know, but this thing is near
> perfect and I'd like to see it get to utter perfection.

Thanks a lot for the feedback, it that kind of feedback i need to make yumex better.


Comment 3 Tim Lauridsen 2005-12-15 04:29:17 EST
(In reply to comment #1)
> 
> Just a note that libnotify will land up in the development tree soonish so you
> might want to use that for providing notifications. 

I did a little googling on 'libnotify', i dont find a lot, but i sound nice,
hope there will be python wrapper for libnotify.

Comment 4 Rahul Sundaram 2005-12-15 11:28:58 EST
(In reply to comment #3)
> (In reply to comment #1)
> > 
> > Just a note that libnotify will land up in the development tree soonish so you
> > might want to use that for providing notifications. 
> 
> I did a little googling on 'libnotify', i dont find a lot, but i sound nice,
> hope there will be python wrapper for libnotify.
> 
> 

libnotify and notify-daemon are in the current development tree. Project page is
http://www.galago-project.org/about.php. For python bindings post to the
fedora-devel list

Comment 5 Tim Lauridsen 2006-02-10 03:02:59 EST
(In reply to comment #0)
> Description of problem:
> 
> Great product, but it could use some small touch ups to make it seem really
> professional. For one thing, it would be cool if you used the notification area
> for updates and stuff so that I don't have to use up two slots of my window bar.

I have tried to used notification by using libnotify/notification daemon, but it
dont work because yumex is running as root, and you can send notification from
root to the normal users notification queue :-(
I the current development release all dialogs, are looked to the parrent window,
so the will only take one slot in the windowbar, and it will flash when a dialog
pops up.

> Second, I think it would be nice if the program told me how far I was into
> installing/updating/removing whatever. If I'm updating 60 apps, I would like to
> at least know how far into it I am. Also, if you've ever updated an iPod with
> iTunes, then you may have noticed that it checks off which ones still need work
> and which ones are updated, so again, you know how far in you are.
>

The current development release has now a total progressbar, so you can se how
much of the operation there is completted.
 
> Third, it would be great if when you resize things on the interface, it would
> apply that to all the various windows that are accessed by the side tabs, like
> if I changed the height of the bottom segment, that would change for all the
> various screens of the program, or if I changed the width of the info fields on
> the update screen (description, name, repo, etc) it would be nice if they also
> changed to the same amount on the install window.
> 

The update,install,remove is now shown in the same view, so position of the
resize bar is the same.



Note You need to log in before you can comment on or make changes to this bug.