Bug 17557 - nfsd oops with 2.216-3smp and 2.2.17smp (custom)
nfsd oops with 2.216-3smp and 2.2.17smp (custom)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-16 01:12 EDT by Dmitri A. Sergatskov
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 11:05:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 2000-09-16 01:12:30 EDT
I start getting oops with both 2.2.16-3smp stock rh6.2 kernel as well as 
with custom compiled 2.2.17smp. The problem exist with both original
nfs-utils-0.1.6 and with update nfs-util-0.1.9.1-1.

The system is a pretty much stock rh6.2.  2 x P-III, ide harddrives and 
scsi (Adaptec 2940) for cd-rw.
Oops piped through ksymoops follows. Any help would be appreciated.
Sincerely,
Dmitri.

-------------------
 
Sep 15 21:59:04 cholla kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000008 
Sep 15 21:59:04 cholla kernel: current->tss.cr3 = 00101000, %cr3 = 00101000 
Sep 15 21:59:04 cholla kernel: *pde = 00000000 
Sep 15 21:59:04 cholla kernel: Oops: 0000 
Sep 15 21:59:04 cholla kernel: CPU:    1 
Sep 15 21:59:04 cholla kernel: EIP:    0010:[nfssvc_encode_attrstat+18/368] 
Sep 15 21:59:04 cholla kernel: EFLAGS: 00010286 
Sep 15 21:59:04 cholla kernel: eax: 00000000   ebx: d6229800   ecx:
00000000   edx: d21e801c 
Sep 15 21:59:04 cholla kernel: esi: d6229800   edi: d21e8014   ebp:
d6229800   esp: d2117f5c 
Sep 15 21:59:04 cholla kernel: ds: 0018   es: 0018   ss: 0018 
Sep 15 21:59:04 cholla kernel: Process nfsd (pid: 927, process nr: 62,
stackpage=d2117000) 
Sep 15 21:59:04 cholla kernel: Stack: d21e8014 c01542de d6229800 d21e801c
c0f48da0 d62298f4 c0235aa0 c0f48ddc  
Sep 15 21:59:04 cholla kernel:        c018af58 d6229800 d21e8014 d2116000
d2116000 00000001 d6229800 c0f48da0  
Sep 15 21:59:04 cholla kernel:        c0235de0 00000001 00000002 000186a3
00000002 d21e8014 c023594c 00000000  
Sep 15 21:59:04 cholla kernel: Call Trace: [nfsd_dispatch+266/344]
[svc_process+692/1316] [nfsd+321/648]
[kernel_thread+35/48]  
Sep 15 21:59:04 cholla kernel: Code: 8b 58 08 85 db 75 07 31 d2 e9 fd 00 00
00 66 8b 43 22 66 c1  

Code:  00000000 Before first symbol            00000000 <_IP>: <===
Code:  00000000 Before first symbol               0:    8b 58
08                mov    0x8(%eax),%ebx <===
Code:  00000003 Before first symbol               3:    85
db                   test   %ebx,%ebx
Code:  00000005 Before first symbol               5:    75
07                   jne     0000000e Before first symbol
Code:  00000007 Before first symbol               7:    31
d2                   xor    %edx,%edx
Code:  00000009 Before first symbol               9:    e9 fd 00 00
00          jmp     0000010b Before first symbol
Code:  0000000e Before first symbol               e:    66 8b 43
22             mov    0x22(%ebx),%ax
Code:  00000012 Before first symbol              12:    66 c1 00
00             rolw   $0x0,(%eax)


7 warnings and 2 errors issued.  Results may not be reliable.
Comment 1 Rex Dieter 2001-04-30 14:23:30 EDT
I'd suggest upgrading both the kernel and nfs-utils to the latest versions 
(currently 2.2.19-6.2.1 and 0.3.1-0.6.x.1 respectively) to see if that helps.
Comment 2 Steve Dickson 2002-12-19 11:05:23 EST
Unable to reproduce in latest release.

Note You need to log in before you can comment on or make changes to this bug.