Bug 175614 - avc denied for fedora-rmdevelrpms and package %preun scriptlets
avc denied for fedora-rmdevelrpms and package %preun scriptlets
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-13 08:14 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.1.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 16:20:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
audit.log for %preun failures (3.47 KB, text/plain)
2005-12-13 08:14 EST, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2005-12-13 08:14:52 EST
selinux-policy-targeted-2.1.4-1 won't allow fedora-rmdevelrpms (from the
fedora-rpmdevtools package in Extras) to properly execute package %preun
scriptlets; at least calls to /sbin/install-info appear to fail:

[scop@gk012 ~]$ sudo -s
[root@gk012 ~]# fedora-rmdevelrpms
Found 4 devel packages:
  autoconf-2.59-5.1
  m4-1.4.4-1
  libtool-1.5.20-5
  automake-1.9.6-1.1
Remove them? [y/N] y
Removing.........error: %preun(autoconf-2.59-5.1.noarch) scriptlet failed, exit
status 255
error: %preun(m4-1.4.4-1.i386) scriptlet failed, exit status 255
error: %preun(libtool-1.5.20-5.i386) scriptlet failed, exit status 255
error: %preun(automake-1.9.6-1.1.noarch) scriptlet failed, exit status 255
Done.
[root@gk012 ~]#

audit.log output attached.
Comment 1 Ville Skyttä 2005-12-13 08:14:52 EST
Created attachment 122177 [details]
audit.log for %preun failures
Comment 2 Ville Skyttä 2005-12-15 16:20:04 EST
Seems to be fixed in 2.1.6-3, thanks.

Note You need to log in before you can comment on or make changes to this bug.