Bug 175681 - i810 driver multihead display doesn't work
i810 driver multihead display doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-13 17:57 EST by Kristo Kriechbaum
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 13:09:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log from a failure. The good stuff is at the bottom. (21.55 KB, text/plain)
2005-12-13 17:57 EST, Kristo Kriechbaum
no flags Details
My xorg.conf file (4.58 KB, text/plain)
2005-12-13 17:58 EST, Kristo Kriechbaum
no flags Details

  None (edit)
Description Kristo Kriechbaum 2005-12-13 17:57:33 EST
Description of problem:
I have a Dell 700m laptop, which has an Intel 855GM chipset.  Under FC3, I was
able to use the vga out as a 2nd head - i.e. I could hook up a monitor to it,
and have the laptop display and crt display both working at the same time.  I
recently upgraded my laptop to FC4 and this doesn't work any longer.  I get a
"Bad V_BIOS checksum" warning followed by a "vm86() syscall generated signal
11." error in my Xorg.log  This happens at 2 different spots, after which X
reports that it can't find any screens to use.

How reproducible:
Always.

Steps to Reproduce:
1. Enable vga-out.
2. (try to) Restart X.
3. X will not restart
  
Actual results:
X will not start, failes with "no screens found".

Expected results:
gdm starts normally, and the multi-head output works.

Additional info:
I will attach an Xorg.log from a failed attempt and my xorg.conf file.
Comment 1 Kristo Kriechbaum 2005-12-13 17:57:33 EST
Created attachment 122203 [details]
X log from a failure.  The good stuff is at the bottom.
Comment 2 Kristo Kriechbaum 2005-12-13 17:58:54 EST
Created attachment 122204 [details]
My xorg.conf file
Comment 3 Matthias Hensler 2006-01-05 07:16:47 EST
I have the same problem with an i855GME chipset. It works with the xorg version
that came with FC4 (just confirmed it yesterday), but not with the xorg version
from Fedora Updates.

Starting X with an Xorg.conf that worked with FC3 and FC4-base is ok, when using
xorg from Updates the CPU will go up to 100% and nothing happens until I kill X
remotely using SSH.

The last few lines in Xorg.0.log are the following:

(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.a
(II) I810(0): initializing int10
(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): Primary V_BIOS segment is: 0xc000

As already discussed with Mike in #fedora removing of linux/libint10.a does not
help. Trying to set DDC to false does not change anything. Different various
parameters I tried had also no effect.

The problem is reproduceable by any combination of MonitorLayout in the
Device-section.
As long as there are heads on both pipes the X server will hang as described above.

Layouts like "CRT,LFP", "LFP,CRT", "CRT,CRT", "CRT+LFP,LFP", etc. will cause the
problem above, while "LFP+CRT,NONE" works (but of course only with single head).

I tried various combination of the i810_drv.o module from different Fedora Xorg
versions and versions I found in several wikis, but only the Xorg version from
Fedora base seems to work reliable.

An issue that might be related is, that I cannot use XV with movies that are
bigger than the virtual resolution anymore.
Playing an 1080i MPEG2 on my 1024x768 primary head works with mplayer and xine
in both fullscreen and windowmode when using Xorg from FC4-base, but does not
with FC4-Update.

Message from mplayer is: "X11 error: BadAlloc (insufficient resources for
operation)". That should be no memory problem, as I have 32 MB allocated for X,
and works with FC4-base and the same configuration.

In order to display with FC4-update I need to enable my external 1600x1200
display as single head.

Since FC4-base works without problem that might be a regression because of the
merging with the i915 driver in the recent xorg version.

Mike: if you have any updated packages of modular Xorg that would work without
too much pain in FC4 I am willing to try them in order to make sure that the
problem is fixed in upcoming FC5.
Comment 4 Mike A. Harris 2006-03-08 04:54:42 EST
If this issue turns out to still be reproduceable in the latest
updates for this Fedora Core release, please file a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in
the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug report URL for tracking.

Thanks in advance.
Comment 5 Matthias Hensler 2006-03-08 05:06:36 EST
The problem is still reproduceable with all latest updates applied. No dualhead
is possible, every using of "MonitorLayout" leads to X-server hanging.

However, using http://www.fairlite.demon.co.uk/i810_drv.o from
http://www.fairlite.demon.co.uk/intel.html solves the problem. That is the
latest i810 driver available and works fine with Fedoras xorg package.

The bug is tracked at https://bugs.freedesktop.org/show_bug.cgi?id=3105

Regards
Comment 6 Mike A. Harris 2006-03-08 06:23:34 EST
(In reply to comment #5)
> The problem is still reproduceable with all latest updates applied. No dualhead
> is possible, every using of "MonitorLayout" leads to X-server hanging.
> 
> However, using http://www.fairlite.demon.co.uk/i810_drv.o from
> http://www.fairlite.demon.co.uk/intel.html solves the problem. That is the
> latest i810 driver available and works fine with Fedoras xorg package.
> 
> The bug is tracked at https://bugs.freedesktop.org/show_bug.cgi?id=3105
> 
> Regards

However, your comments are describing a problem unrelated to what the original
reporter of this bug reported.  This bug is tracking that specific issue only.

When reviewing bugs in bugzilla, please do not add comments/info for unrelated
problems on the same hardware, as it makes the existing bug hard to read. 
File a separate bug report instead, and include all details there.

Comment 7 Kristo Kriechbaum 2006-03-11 19:38:35 EST
I created a new bug in the freedesktoip bugzilla:
https://bugs.freedesktop.org/show_bug.cgi?id=6231
Comment 8 Kristo Kriechbaum 2006-03-14 19:31:01 EST
I can report that the experimental i810_drv.o referenced comment #5 does fix
this problem.  Nothing besides replacing
/usr/X11R6/lib/modules/drivers/i810_drv.o with the experimental version was
necessary.
Comment 9 Mike A. Harris 2006-06-14 13:09:22 EDT
Closing bug as fixed in rawhide, as per comments in upstream bug.

Note You need to log in before you can comment on or make changes to this bug.