Bug 175686 - Applications missing from Gnome menus.
Applications missing from Gnome menus.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setools (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-13 19:35 EST by bkyoung
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-02 11:46:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Spec file patch for quick solution. (8.75 KB, patch)
2005-12-13 19:36 EST, bkyoung
no flags Details | Diff
Desktop file patch for quick solution. (549 bytes, patch)
2005-12-13 19:37 EST, bkyoung
no flags Details | Diff
Desktop file patch for quick solution. (555 bytes, patch)
2005-12-13 19:37 EST, bkyoung
no flags Details | Diff
Desktop file patch for quick solution. (555 bytes, patch)
2005-12-13 19:38 EST, bkyoung
no flags Details | Diff

  None (edit)
Description bkyoung 2005-12-13 19:35:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051202 Fedora/1.5-1 Firefox/1.5

Description of problem:
Application entries not present in gnome menus.

Version-Release number of selected component (if applicable):
setools-2.2-3

How reproducible:
Always

Steps to Reproduce:
1.Search among the Gnome menus.


Actual Results:  Unable to find application launchers.

Expected Results:  After setools-gui is installed, should be able to launch apol, seaudit, and sediffx from menus.

Additional info:

Attaching some patches, and a spec file patch for one solution. Probably not backward compatible.
Comment 1 bkyoung 2005-12-13 19:36:30 EST
Created attachment 122205 [details]
Spec file patch for quick solution.
Comment 2 bkyoung 2005-12-13 19:37:23 EST
Created attachment 122206 [details]
Desktop file patch for quick solution.
Comment 3 bkyoung 2005-12-13 19:37:55 EST
Created attachment 122207 [details]
Desktop file patch for quick solution.
Comment 4 bkyoung 2005-12-13 19:38:29 EST
Created attachment 122208 [details]
Desktop file patch for quick solution.
Comment 5 bkyoung 2005-12-13 19:40:08 EST
libapol looks like it is not being built with -fPIC.
Comment 6 Daniel Walsh 2005-12-14 09:44:25 EST
Your fixes are in setools-2.2-4

-fPIC comes from the Makefile one level up.
Comment 7 bkyoung 2005-12-14 15:00:28 EST
>-fPIC comes from the Makefile one level up.
Yep. It turned out to be a non-pic -lfl static archive dependency getting linked
into pic shared object libapol.

Note You need to log in before you can comment on or make changes to this bug.