Bug 175705 - libgcj breaks yum update
libgcj breaks yum update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-13 21:41 EST by Peter Quiring
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-13 21:45:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Quiring 2005-12-13 21:41:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051211 Fedora/1.5-1.1 Firefox/1.5

Description of problem:
Can't do a complete 'yum update' due to dependecy issues with libgcj package.

yum update output: (error lines only)
Error: hwdata conflicts with pcmcia-cs
Error: Missing Dependency: libgcj.so.6 is needed by package xalan-j2
Error: Missing Dependency: libgcj.so.6 is needed by package tomcat5-servlet-2.4-api
Error: Missing Dependency: libgcj.so.6 is needed by package gnu-crypto
Error: Missing Dependency: libgcj.so.6 is needed by package gnu-crypto-sasl-jdk1.4
Error: Missing Dependency: libgcj.so.6 is needed by package gnu-crypto-jce-jdk1.4
Error: Missing Dependency: libgcjawt.so.6 is needed by package openoffice.org-core
Error: Missing Dependency: libgcj.so.6 is needed by package xml-commons-apis
Error: Missing Dependency: libgcj.so.6 is needed by package openoffice.org-core
Error: Missing Dependency: libgcj.so.6 is needed by package xerces-j2

This error occurs sometimes (when doing selective updates, ie: 'yup update "h*"')
Error: Package tuple ('libgcj', 'i386', '0', '4.0.2', '6') could not be found in packagesack



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.yum update
2.
3.
  

Actual Results:  yum fails to updates packages.

Expected Results:  yum updates packages.

Additional info:

I've been updating other packages selectively for a few days now.
Comment 1 Jeremy Katz 2005-12-13 21:45:20 EST
This isn't a yum bug, things are in flux as gcc 4.1 moves into the tree with an
incompatible libgcj
Comment 2 Peter Quiring 2005-12-14 14:57:29 EST
FYI : I think if you manually install (-i --force) the new libgcj-4.1 then
things should work out nicely.  I've done this but the login screen has problems
loading now and it fallsback to an older program to do this.  The About Gnome
applet also crashes after doing this, but most apps seem to work.

Note You need to log in before you can comment on or make changes to this bug.