Bug 175705 - libgcj breaks yum update
Summary: libgcj breaks yum update
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-14 02:41 UTC by Peter Quiring
Modified: 2014-01-21 22:53 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-12-14 02:45:20 UTC


Attachments (Terms of Use)

Description Peter Quiring 2005-12-14 02:41:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051211 Fedora/1.5-1.1 Firefox/1.5

Description of problem:
Can't do a complete 'yum update' due to dependecy issues with libgcj package.

yum update output: (error lines only)
Error: hwdata conflicts with pcmcia-cs
Error: Missing Dependency: libgcj.so.6 is needed by package xalan-j2
Error: Missing Dependency: libgcj.so.6 is needed by package tomcat5-servlet-2.4-api
Error: Missing Dependency: libgcj.so.6 is needed by package gnu-crypto
Error: Missing Dependency: libgcj.so.6 is needed by package gnu-crypto-sasl-jdk1.4
Error: Missing Dependency: libgcj.so.6 is needed by package gnu-crypto-jce-jdk1.4
Error: Missing Dependency: libgcjawt.so.6 is needed by package openoffice.org-core
Error: Missing Dependency: libgcj.so.6 is needed by package xml-commons-apis
Error: Missing Dependency: libgcj.so.6 is needed by package openoffice.org-core
Error: Missing Dependency: libgcj.so.6 is needed by package xerces-j2

This error occurs sometimes (when doing selective updates, ie: 'yup update "h*"')
Error: Package tuple ('libgcj', 'i386', '0', '4.0.2', '6') could not be found in packagesack



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.yum update
2.
3.
  

Actual Results:  yum fails to updates packages.

Expected Results:  yum updates packages.

Additional info:

I've been updating other packages selectively for a few days now.

Comment 1 Jeremy Katz 2005-12-14 02:45:20 UTC
This isn't a yum bug, things are in flux as gcc 4.1 moves into the tree with an
incompatible libgcj

Comment 2 Peter Quiring 2005-12-14 19:57:29 UTC
FYI : I think if you manually install (-i --force) the new libgcj-4.1 then
things should work out nicely.  I've done this but the login screen has problems
loading now and it fallsback to an older program to do this.  The About Gnome
applet also crashes after doing this, but most apps seem to work.


Note You need to log in before you can comment on or make changes to this bug.