Bug 175713 - driver i810 does not work with intel 915 GM
driver i810 does not work with intel 915 GM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 175715 175716 175717 175718 175719 175721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-14 05:09 EST by Steffen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 04:31:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steffen 2005-12-14 05:45:44 EST
kernel: 2.6.11-1.1369_FC4 / xorg-x11-6.8.2-31

My Hardware is laptop FS Lifebook S7020 with intel 915GM.
After a fresh installation of FC-4 (2.6.11-1.1369) the display only allows to
change to maximum 800 x 600. The xorg.conf is configured like this: 
at Section "Device":
Driver "vesa" 
Boardname "VESA driver (generic)"

I have changed via "system-config-display" the Hardware 
monitor to:
Generic LCD Display => LCD Panel 1280x800
Graphiccard to: Intel 810

The result is a x-server complaining bluescreen...even after a lot of other
tries with different monitor and graphiccard settings.

I have tried the 915resolution-tool (http://www.geocities.com/stomljen) and even
this did not work...


Hope you can help me
Thanks in advance
Steffen

btw: I have UBUNTU on the same Harddisk and that works just fine....





/var/log/messages shows:

Dec 14 10:12:42 localhost gdm[3654]: gdm_slave_xioerror_handler: Schwerwiegender
X-Fehler - :0 wird neu gestartet
Dec 14 10:12:47 localhost gdm[3696]: gdm_slave_xioerror_handler: Schwerwiegender
X-Fehler - :0 wird neu gestartet
Dec 14 10:12:51 localhost gdm[3752]: gdm_slave_xioerror_handler: Schwerwiegender
X-Fehler - :0 wird neu gestartet
Dec 14 10:12:51 localhost gdm[3612]: deal_with_x_crashes: Das Skript
XKeepsCrashing wird gestartet
Dec 14 10:23:38 localhost gdm[3612]: X-Server konnte nicht in kurzen
Zeitabständen gestartet werden; Anzeige :0 wird deaktiviert

/var/log/Xorg.0.log.old shows:

(--) PCI:*(0:2:0) Intel Corp. unknown chipset (0x2592) rev 3, Mem @
0xb0080000/19, 0xc0000000/28, 0xb0040000/18, I/O @ 0x1400/3
.
.
(II) Reloading /usr/X11R6/lib/modules/input/synaptics_drv.o
(II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
	i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G
(II) Primary Device is: PCI 00:02:0
(--) Assigning device section with no busID to primary device
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(EE) No devices detected.

Fatal server error:
no screens found
Comment 1 Thorsten Scherf 2005-12-14 09:21:10 EST
the section in question looks like this:

Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
        VendorName  "Videocard vendor"
        BoardName   "Intel 810"
EndSection
Comment 2 Steffen 2005-12-14 11:09:59 EST
*** Bug 175715 has been marked as a duplicate of this bug. ***
Comment 3 Steffen 2005-12-14 11:10:56 EST
*** Bug 175716 has been marked as a duplicate of this bug. ***
Comment 4 Steffen 2005-12-14 11:12:53 EST
*** Bug 175717 has been marked as a duplicate of this bug. ***
Comment 5 Steffen 2005-12-14 11:13:43 EST
*** Bug 175718 has been marked as a duplicate of this bug. ***
Comment 6 Steffen 2005-12-14 11:14:25 EST
*** Bug 175719 has been marked as a duplicate of this bug. ***
Comment 7 Steffen 2005-12-14 11:14:58 EST
*** Bug 175721 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2005-12-14 15:09:13 EST
Holy duplicate bugs batman! ;o)
Comment 9 Mike A. Harris 2005-12-14 16:39:25 EST
After any OS install, you should run "yum update" to ensure you are running
the latest packages, which might solve any problems that you experience with
the default packages that come with the OS.

Please update the report after you update.
Comment 10 Steffen 2005-12-15 04:31:15 EST
Great!!! Thanks a lot! works just fine with the latest updates...
sorry for killing your nerves with this easy stuff...;-)


Note You need to log in before you can comment on or make changes to this bug.