Bug 175740 - rpm --verify reports spurious md5 errors for empty files
rpm --verify reports spurious md5 errors for empty files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2005-12-14 09:20 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0440
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-12-14 09:20:23 EST
Patch might need updating. Let me know if it does.

+++ This bug was initially created as a clone of Bug #159405 +++

If you use "rpm --verify" on a package with empty files, rpm will report "?" 
in the MD5 column for the empty files.  This is because mmap files when you 
try to map a file of length zero.  Whether that failure is correct is, I 
suppose, a matter of some debate; the man page doesn't make it clear, although 
the specs may be clearer.  In any case, the attached patch eliminates the 
problem.

-- Additional comment from jik@kamens.brookline.ma.us on 2005-06-02 10:01 EST --
Created an attachment (id=115085)
patch not to try to mmap empty files
Comment 1 Jeff Johnson 2006-01-06 07:36:09 EST
Fixed (by adding patch) in rpm-4.4.2 and later.
Comment 2 Bastien Nocera 2006-01-06 07:47:38 EST
The updated package with that patch hasn't been released. Don't close.
Comment 3 Jeff Johnson 2006-01-07 10:59:33 EST
NEEDINFO then so that I don't have to stare at a problem that is already fixed.
Comment 7 Bob Johnson 2006-04-11 11:57:34 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 12 Red Hat Bugzilla 2006-08-10 17:49:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0440.html

Note You need to log in before you can comment on or make changes to this bug.