Bug 175744 - gnupg2: contains references to non-FHS-compliant directories: /usr/env, /usr/shutdown
gnupg2: contains references to non-FHS-compliant directories: /usr/env, /usr/...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnupg2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-14 09:51 EST by Nils Philippsen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.9.20-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-19 22:04:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix directories (1.05 KB, patch)
2006-02-19 07:47 EST, Ignacio Vazquez-Abrams
no flags Details | Diff

  None (edit)
Description Nils Philippsen 2005-12-14 09:51:45 EST
gnupg2 contains a directory /usr/shutdown (containing only one script) which IMO
is not FHS-compliant, this script should be moved elsewhere.

Version-Release number of selected component (if applicable):

gnupg2-1.9.19-8.fc4
Comment 1 Rex Dieter 2005-12-14 10:43:18 EST
KDE uses /usr/env and /usr/shutdown for  source'd startup/shutdown scripts (See
kdebase's /usr/bin/startkde for usage).  The only reason I made gnupg2 own them
is because kdebase doesn't (yet).

So, if you want to argue FHS-ness, IMO, the issue should be taken against kdebase.
Comment 2 Rex Dieter 2005-12-14 11:07:55 EST
Completing Reassignment to kdebase.
Comment 3 Nils Philippsen 2005-12-14 11:39:08 EST
Thanks, the browser broke in the midst of it.
Comment 4 Rex Dieter 2006-02-15 13:17:39 EST
See bug #178326 "create/own /usr/env,/usr/shutdown".  In short, env and shutdown
have been moved to /etc/kde, which effectively makes this a dup.

*** This bug has been marked as a duplicate of 178326 ***
Comment 5 Rex Dieter 2006-02-16 14:42:34 EST
Re-opening, pending modification to use 
Comment 6 Rex Dieter 2006-02-16 14:43:54 EST
What I was trying to say... re-opening pending modification to use new
/etc/kde/env,/etc/kde/shutdown locations.
Comment 7 Ignacio Vazquez-Abrams 2006-02-19 07:47:47 EST
Created attachment 124862 [details]
Patch to fix directories

This patch is for FE4, but it should apply against devel as well.
Comment 8 Rex Dieter 2006-02-19 08:53:08 EST
This has already been fixed in gnupg2-1.9.20-2

Will release an update to fc4 when/if an updated kdebase is released.
Comment 9 Rex Dieter 2006-02-19 08:54:20 EST
Nevermind... looks an update for fc4 *has* been released... reopening.
Comment 10 Rex Dieter 2006-02-19 22:04:22 EST
FC-4 build queued.

Note You need to log in before you can comment on or make changes to this bug.