Bug 175762 - eject in WS4 doesn't work with ATAPI 250 meg zip disks
eject in WS4 doesn't work with ATAPI 250 meg zip disks
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: eject (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Zdenek Prikryl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-14 14:10 EST by Gary Gatling
Modified: 2008-01-24 09:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 09:11:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Gatling 2005-12-14 14:10:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Since upgrading some of my systems to WS4 I am no longer able to
eject IOMEGA zip 250 disks with eject. This worked for me fine under WS3.

Version-Release number of selected component (if applicable):
eject-2.0.13-2

How reproducible:
Always

Steps to Reproduce:
1.in a freshly installed and updated WS4 system with a zip disk drive type:

cat /etc/fstab | grep /media/zip

and the first field in the output will tell you what device the
zip drive is. For this example I"ll choose the behavior of a 
factory installed DELL GX270 which is intalled on /dev/hdb4

In a terminal window type:

eject /dev/hdb4              (or whatever your zip drive device name is)

2. In a terminal window type:

eject -v /dev/hdb4              (or whatever your zip drive device name is)


Actual Results:  I get this error:

eject: device name is `/dev/hdb4'
eject: expanded name is `/dev/hdb4'
eject: `/dev/hdb4' is not mounted
eject: `/dev/hdb4' is not a mount point
eject: `/dev/hdb4' is a multipartition device
eject: trying to eject `/dev/hdb4' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/hdb4' using SCSI commands
eject: SCSI eject failed
eject: trying to eject `/dev/hdb4' using floppy eject command
eject: floppy eject command failed
eject: trying to eject `/dev/hdb4' using tape offline command
eject: tape offline command failed
eject: unable to eject, last error: Invalid argument


Expected Results:  On my WS3 system it just ejects the disk with that command. In WS3
it was the CD-ROM eject command which succeded. WS3 output:

eject -v /dev/hdb4
eject: device name is `/dev/hdb4'
eject: expanded name is `/dev/hdb4'
eject: `/dev/hdb4' is not mounted
eject: `/dev/hdb4' is not a mount point
eject: `/dev/hdb4' is a multipartition device
eject: trying to eject `/dev/hdb4' using CD-ROM eject command
eject: CD-ROM eject command succeeded


Additional info:
Comment 1 Gary Gatling 2005-12-19 09:51:33 EST
I should have mentioned that in WS3 the version was: eject-2.0.13-2
The WS4 component is version: eject-2.0.13-11

I got the version component in this bug wrong. sorry about that.
Comment 2 Zdenek Prikryl 2008-01-24 05:46:22 EST
I looked into a changelog, but it seems, that there is no such change which
could lead to break functionality of eject. I could be a bug in a kernel module,
so what version of the kernel do you have?
Comment 3 Gary Gatling 2008-01-24 08:59:08 EST
I'm sorry. I no longer have any systems with zip drives. Thanks for looking into
this but I guess you can close it since I can't reproduce any longer. sorry
about that.

Note You need to log in before you can comment on or make changes to this bug.